SEO issue? Switched to https, but after a year google still indexing both versions


#1

So i switched my forum https://wmforum.geek.hr from http to https almost year ago and i have proper redirects in place.

However google has indexed my homepage as https but other urls stayed indexed as http.

How to i force google to list all urls as https? I also get different results for http and https versions in Google Webmaster Tools search analytics.


(Sam Saffron) #2

It appears you are using CloudFlare to do the https redirection and not our officially supported HTTPS template in Discourse Docker.

Looking at:

sam@ubuntu puppet-config % curl -I https://wmforum.geek.hr/test
HTTP/1.1 404 Not Found
Date: Fri, 17 Nov 2017 00:07:48 GMT
Content-Type: text/html; charset=utf-8
Connection: keep-alive
Set-Cookie: __cfduid=dd43a74cf50c568c420765907f082f80c1510877267; expires=Sat, 17-Nov-18 00:07:47 GMT; path=/; domain=.geek.hr; HttpOnly
Vary: Accept-Encoding
X-Frame-Options: SAMEORIGIN
X-XSS-Protection: 1; mode=block
X-Content-Type-Options: nosniff
X-Discourse-Route: exceptions/not_found
X-Request-Id: df9400b2-0b8b-422d-937b-59123f0a9603
X-Runtime: 0.076966
Server: cloudflare-nginx
CF-RAY: 3bee73a71a89850e-HKG

I am seeing no sts header like we have in our official template.

strict-transport-security:max-age=31536000

So it does not surprise me that google is just getting confused here.


#3

Ok i enaled this option:

Should it work now? Or i must do something else?


(Sam Saffron) #4

Something else, cause that header comes from NGINX, you need your NGINX to set this, I would strongly recommend disabling all cloudflare “acceleration” and using the ssl setup we recommend.


(Jay Pfaffman) #5

I noticed that cloudflare template just today. Would that have solved the other recent cloudflare problems?

My observation is lots of people have trouble with cloudflare. I don’t know whether that has to do with cloudflare or the nature of the problem that cloudflare is trying to solve.

I know you guys use Fastly. I never see anyone with trouble with Fastly. I don’t know if that’s because it works without any trouble, or fewer people use it. (I tried to figure it outl for a client for a few minutes before deciding I didn’t want to for the available budget).


(Sam Saffron) #6

We actually use:

  • Cloudfront (aws) on meta now
  • KeyCDN on the majority of our sites
  • MaxCDN on a smaller subset of our sites
  • Fastly on an even smaller subset of our sites

This particular issue is unrelated to the recent cloudflare problem. Its simply that the https origin is not adding the header it needs to ensure that all traffic is https.


(Jay Pfaffman) #7

Aha! That’s good to know. I did configure KeyCDN for someone; it wasn’t that difficult, and it’s reasonably priced.