Server Error while trying to load /admin/dashboard/general.json

If I navigate to the admin area,

I keep getting this error :


Server Error

while trying to load [/admin/dashboard/general.json](

Error code: 502 error

It pops up after some seconds whenever I click on any tab on the admin area.

Pls, this happened after updating to the latest discourse.

How do I fix this please?

Try disabling any third party plugins first, and rebuilding.

Pls, is there an official tutorial on how to do this?

First question: do you know if you have installed third party plugins?

Yes, I do. I can see them in a list if I access app.yml

Give this a try

The problem persists in safe mode. I left all the three options as they are i.e default options

1 Like

And here is my plugins list after removing the branding and navigation plugins.

I guess these ones here are official plugins

Those are all official so not third party.

1 Like

Are there any related errors the logs?

Also, try clicking on the /admin/dashboard/general.json link when you get the error 502. It might reveal details about the problem as well.

2 Likes leads to a “502 bad gateway” page.

Nothing recorded in the log since monday after I fmade changes to the Facebook login as required after changing the forum’s url from to

The problem started before I changed the forum url though. Can I share screenshot of the logs page here? @codinghorror @gerhard

I’ve been having the same problem for a while now, at the beginning searched for the solution, coulnd’t find much and gave up. For me it happened with one of the previous upgrades, I hadn’t made any other changes in terms of setup, plugins etc. Everything else seems to be working, only general page is failing. Just upgraded to the latest image but the issue is still there.

Are you by any chance uploading your backups to S3 and reusing the s3_upload_bucket for backups?

I’m probably going to fix this next week. And we will prevent reusing the same bucket. It’s causing too many problems.


Changing back up location to “local” seems to have fixed the problem. I will create another bucket for the backup. Thanks @gerhard.


Setting backup location to s3 and adding “/discoursebackups” prefix to the existing s3 bucket in the settings also work…


adding folder under the existing bucket worked for me as well.

1 Like