# Server not response (DO SGP1)

**URL:** https://meta.discourse.org/t/server-not-response-do-sgp1/43628
**Category:** Self-hosting
**Created:** [May 3, 2016, 6:38pm UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628 "2016-05-03T18:38:12Z")
**Posts on this page:** 17
**Page:** 1

<div class="post-metadata">

### Author: ![rsoutar](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rsoutar/32/121260_2.png) [@rsoutar](https://meta.discourse.org/u/rsoutar)
#### Post date: [May 3, 2016, 6:38pm UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/1 "2016-05-03T18:38:12Z")

</div>

Hi guys,

For the past few days I had a problem that DO server CPU spike for unknown reason.

Here’s the $ top command. It seems the postmaster was busy.

 ![](https://global.discourse-cdn.com/meta/original/3X/1/f/1f62a653d48d2789451d2c7bd54bd9651a956598.png)

I only had 509 users on DO 2GB memory.

---

<div class="post-metadata">

### Author: ![rsoutar](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rsoutar/32/121260_2.png) [@rsoutar](https://meta.discourse.org/u/rsoutar)
#### Post date: [May 3, 2016, 6:49pm UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/3 "2016-05-03T18:49:40Z")

</div>

No. I use Mailgun.

What I did after that was ./lanucher rebuild app. now It’s error 502 bad gateway.

---

<div class="post-metadata">

### Author: ![downey](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/downey/32/166878_2.png) [@downey](https://meta.discourse.org/u/downey)
#### Post date: [May 3, 2016, 6:50pm UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/4 "2016-05-03T18:50:46Z")

</div>

Sorry, I totally misread your issue as postfix and not postmaster. 🙂

---

<div class="post-metadata">

### Author: ![rsoutar](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rsoutar/32/121260_2.png) [@rsoutar](https://meta.discourse.org/u/rsoutar)
#### Post date: [May 3, 2016, 10:47pm UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/5 "2016-05-03T22:47:19Z")

</div>

I got his error from my log. After ran rebuild again.

```
FAILED
--------------------
RuntimeError: su postgres -c 'psql discourse -c "alter schema public owner to di scourse;"' failed with return #<Process::Status: pid 91 exit 2>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params "su postgres -c 'psql $db_name -c \"alter schema pub lic owner to $db_user;\"'"
8c5331f9905f986b28e3c6fe278f3a4a876ccb3caea9c42341cba440295a1e71
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one
root@forum:/var/discourse# ./launcher rebuild app
Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
Stopping old container

```

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 4, 2016, 12:18am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/6 "2016-05-04T00:18:10Z")

</div>

Yep, you will need to read what is on the screen there, “scroll up and look for error”.

Edit: check free disk space and free memory.

---

<div class="post-metadata">

### Author: ![rsoutar](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rsoutar/32/121260_2.png) [@rsoutar](https://meta.discourse.org/u/rsoutar)
#### Post date: [May 10, 2016, 8:11am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/7 "2016-05-10T08:11:34Z")

</div>

I have found out that every couple of days. The disk will be full.

 ![](https://global.discourse-cdn.com/meta/original/3X/2/2/22bcefe97a09713d8fef77c8f6e4f6a9a8f024f0.png)

It was /var/discourse/shared/standalone/log/rails/unicorn.stderr.log that got 20+ GB in 9 hours. I deleted the log but some context of the log was

`Failed to report error: EXECABORT Transaction discarded because of previous errors. 3 Job exception: MISCONF Redis is configured to save RDB snapshots, but is currently not able to persist on disk. Commands that may modify the data set are disabled. Please check Redis logs for details about the error.`

---

<div class="post-metadata">

### Author: ![mpalmer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mpalmer/32/45740_2.png) [@mpalmer](https://meta.discourse.org/u/mpalmer)
#### Post date: [May 10, 2016, 8:23am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/8 "2016-05-10T08:23:25Z")

</div>

> [@rsoutar](#):
>
> Please check Redis logs for details about the error.

… and what did the Redis logs have to say?

---

<div class="post-metadata">

### Author: ![rsoutar](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rsoutar/32/121260_2.png) [@rsoutar](https://meta.discourse.org/u/rsoutar)
#### Post date: [May 10, 2016, 8:25am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/9 "2016-05-10T08:25:46Z")

</div>

Sorry, I have no idea where Redis log is.

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 10, 2016, 8:46am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/10 "2016-05-10T08:46:54Z")

</div>

It looks like there is something broken about your install. Did you follow our [official install](https://meta.discourse.org/t/142537?silent=true) guide, to the letter? Did you deviate from any steps in the install in any way, however small?

---

<div class="post-metadata">

### Author: ![rsoutar](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rsoutar/32/121260_2.png) [@rsoutar](https://meta.discourse.org/u/rsoutar)
#### Post date: [May 10, 2016, 8:48am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/11 "2016-05-10T08:48:28Z")

</div>

I use a one-click installation from Digital Ocean.

It’s been running fine since December '15. This started to occur for the past 2 weeks.

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 10, 2016, 8:51am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/12 "2016-05-10T08:51:08Z")

</div>

Ok, then try the following to free up some disk space:

```
apt-get autoclean
apt-get autoremove
cd /var/discourse
./launcher cleanup

```

See how much space that clears first.

Something is causing massive numbers of errors in your logs, I presume? Hard to say without looking at them. You’ll need to poke around.

---

<div class="post-metadata">

### Author: ![rsoutar](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rsoutar/32/121260_2.png) [@rsoutar](https://meta.discourse.org/u/rsoutar)
#### Post date: [May 10, 2016, 8:56am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/13 "2016-05-10T08:56:00Z")

</div>

Here’s before cleanup

```
root@forum:/var/discourse/shared/standalone/log/rails# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/vda1 40G 13G 26G 33% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
udev 991M 4.0K 991M 1% /dev
tmpfs 201M 352K 200M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 1001M 864K 1001M 1% /run/shm
none 100M 0 100M 0% /run/user
root@forum:/var/discourse/shared/standalone/log/rails#

```

After cleanup

```
Filesystem Size Used Avail Use% Mounted on
/dev/vda1 40G 4.7G 33G 13% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
udev 991M 4.0K 991M 1% /dev
tmpfs 201M 352K 200M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 1001M 868K 1001M 1% /run/shm
none 100M 0 100M 0% /run/user

```

I will keep monitoring the log again.

---

<div class="post-metadata">

### Author: ![rsoutar](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rsoutar/32/121260_2.png) [@rsoutar](https://meta.discourse.org/u/rsoutar)
#### Post date: [May 10, 2016, 6:36pm UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/14 "2016-05-10T18:36:03Z")

</div>

It happened again.

```
E, [2016-05-10T18:35:04.540407 #62] ERROR -- : config/unicorn.conf.rb:99:in `out_of_memory?'
E, [2016-05-10T18:35:04.540448 #62] ERROR -- : config/unicorn.conf.rb:122:in `check_sidekiq_heartbeat'
E, [2016-05-10T18:35:04.540489 #62] ERROR -- : config/unicorn.conf.rb:146:in `master_sleep'
E, [2016-05-10T18:35:04.540529 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/unicorn-5.0.1/lib/unicorn/http_server.rb:284:in `join'
E, [2016-05-10T18:35:04.540571 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/unicorn-5.0.1/bin/unicorn:126:in `<top (required)>'
E, [2016-05-10T18:35:04.540615 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/bin/unicorn:22:in `load'
E, [2016-05-10T18:35:04.540656 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/bin/unicorn:22:in `<main>'
E, [2016-05-10T18:35:04.540908 #62] ERROR -- : master loop error: Cannot allocate memory - ps -eo rss,args | grep sidekiq | grep -v grep | awk '{print $1}' (Errno::ENOMEM)
E, [2016-05-10T18:35:04.540975 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.6/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``'
E, [2016-05-10T18:35:04.541021 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.6/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``'
E, [2016-05-10T18:35:04.541072 #62] ERROR -- : config/unicorn.conf.rb:84:in `max_rss'
E, [2016-05-10T18:35:04.541120 #62] ERROR -- : config/unicorn.conf.rb:99:in `out_of_memory?'
E, [2016-05-10T18:35:04.541162 #62] ERROR -- : config/unicorn.conf.rb:122:in `check_sidekiq_heartbeat'
E, [2016-05-10T18:35:04.541213 #62] ERROR -- : config/unicorn.conf.rb:146:in `master_sleep'
E, [2016-05-10T18:35:04.541264 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/unicorn-5.0.1/lib/unicorn/http_server.rb:284:in `join'
E, [2016-05-10T18:35:04.541309 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/unicorn-5.0.1/bin/unicorn:126:in `<top (required)>'
E, [2016-05-10T18:35:04.541367 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/bin/unicorn:22:in `load'
E, [2016-05-10T18:35:04.541412 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/bin/unicorn:22:in `<main>'
E, [2016-05-10T18:35:04.541663 #62] ERROR -- : master loop error: Cannot allocate memory - ps -eo rss,args | grep sidekiq | grep -v grep | awk '{print $1}' (Errno::ENOMEM)
E, [2016-05-10T18:35:04.541729 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.6/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``'
E, [2016-05-10T18:35:04.541775 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.6/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``'
E, [2016-05-10T18:35:04.541819 #62] ERROR -- : config/unicorn.conf.rb:84:in `max_rss'
E, [2016-05-10T18:35:04.541862 #62] ERROR -- : config/unicorn.conf.rb:99:in `out_of_memory?'
E, [2016-05-10T18:35:04.541908 #62] ERROR -- : config/unicorn.conf.rb:122:in `check_sidekiq_heartbeat'
E, [2016-05-10T18:35:04.541950 #62] ERROR -- : config/unicorn.conf.rb:146:in `master_sleep'
E, [2016-05-10T18:35:04.541991 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/unicorn-5.0.1/lib/unicorn/http_server.rb:284:in `join'
E, [2016-05-10T18:35:04.542033 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/unicorn-5.0.1/bin/unicorn:126:in `<top (required)>'
E, [2016-05-10T18:35:04.542076 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/bin/unicorn:22:in `load'
E, [2016-05-10T18:35:04.542117 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/bin/unicorn:22:in `<main>'
E, [2016-05-10T18:35:04.542359 #62] ERROR -- : master loop error: Cannot allocate memory - ps -eo rss,args | grep sidekiq | grep -v grep | awk '{print $1}' (Errno::ENOMEM)
E, [2016-05-10T18:35:04.542426 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.6/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``'
E, [2016-05-10T18:35:04.542472 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.6/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``'
E, [2016-05-10T18:35:04.542515 #62] ERROR -- : config/unicorn.conf.rb:84:in `max_rss'
E, [2016-05-10T18:35:04.542557 #62] ERROR -- : config/unicorn.conf.rb:99:in `out_of_memory?'
E, [2016-05-10T18:35:04.542597 #62] ERROR -- : config/unicorn.conf.rb:122:in `check_sidekiq_heartbeat'
E, [2016-05-10T18:35:04.542638 #62] ERROR -- : config/unicorn.conf.rb:146:in `master_sleep'
E, [2016-05-10T18:35:04.542684 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/unicorn-5.0.1/lib/unicorn/http_server.rb:284:in `join'
E, [2016-05-10T18:35:04.542732 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/unicorn-5.0.1/bin/unicorn:126:in `<top (required)>'
E, [2016-05-10T18:35:04.542776 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/bin/unicorn:22:in `load'
E, [2016-05-10T18:35:04.542817 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/bin/unicorn:22:in `<main>'
E, [2016-05-10T18:35:04.543081 #62] ERROR -- : master loop error: Cannot allocate memory - ps -eo rss,args | grep sidekiq | grep -v grep | awk '{print $1}' (Errno::ENOMEM)
E, [2016-05-10T18:35:04.543158 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.6/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``'
E, [2016-05-10T18:35:04.543207 #62] ERROR -- : /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/activesupport-4.2.6/lib/active_support/core_ext/kernel/agnostics.rb:7:in ``'
E, [2016-05-10T18:35:04.543251 #62] ERROR -- : config/unicorn.conf.rb:84:in `max_rss'
E, [2016-05-10T18:35:04.543293 #62] ERROR -- : config/unicorn.conf.rb:99:in `out_of_memory?'
E, [2016-05-10T18:35:04.543334 #62] ERROR -- : config/unicorn.conf.rb:122:in `check_sidekiq_heartbeat'
E, [2016-05-10T18:35:04.543375 #62] ERROR -- : config/unicorn.conf.rb:146:in `master_sleep'

```

infinite loop this message.

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 10, 2016, 11:26pm UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/15 "2016-05-10T23:26:01Z")

</div>

Are you using any third-party plugins? Any unusual settings? I am not aware of any persistent out of memory issues on our Docker based DO installs.

Do you have a swapfile? It shouldn’t matter except for upgrades, but given the problems you’re having, I would set a 2GB swapfile up quickly.

---

<div class="post-metadata">

### Author: ![rsoutar](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rsoutar/32/121260_2.png) [@rsoutar](https://meta.discourse.org/u/rsoutar)
#### Post date: [May 11, 2016, 8:34am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/16 "2016-05-11T08:34:06Z")

</div>

No, I did not install any third-party plugins. I do not have a swapfile. I’ll have it setup now.

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [May 17, 2016, 5:40am UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/17 "2016-05-17T05:40:35Z")

</div>

Please try

```plaintext
cd /var/discourse
./launcher rebuild app
./launcher cleanup

```

We had a rather urgent fix related to tagging that could cause disks to fill up

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [June 8, 2024, 12:45pm UTC](https://meta.discourse.org/t/server-not-response-do-sgp1/43628/18 "2024-06-08T12:45:40Z")

</div>

This topic was automatically closed after 2957 days. New replies are no longer allowed.
