Service email not woking


(Cheng Trang) #1

I using mailgun for service email…
I config ok like How to configure Mailgun Email Server on Discourse Forum correct way? - Detailed and Verified Steps • Crunchify
But when register not send message verify.
I send email test (/admin/email) but not working


Please help me.


(Mittineague) #2

I have no idea how correct the crunchify instructions are, but there is a troubleshooting how to that should help


(Bhanu Sharma) #3

Mailgun needs You to either add Your admin ID to be added to be added to a list called authorized recipients as there is a time gap between them moving Your account from screened accounts to normal accounts!

You can check for that and also, You can try cross checking your app.yml if all details are stored correctly. if not, try to rectify the details and rebuild your container.


(Cheng Trang) #4

This is my config in app,yml

DISCOURSE_SMTP_ADDRESS: smtp.mailgun.org
DISCOURSE_SMTP_USER_NAME: postmaster@site.info
DISCOURSE_SMTP_PASSWORD: pasword
#DISCOURSE_SMTP_PORT: 465
#DISCOURSE_SMTP_ENABLE_START_TLS: true # (optional, default true)
I verify domain on mailgun Successfully.


(Bhanu Sharma) #5

You should not post Your contents here!

if You want to exchange sensitive information, Use the DM


(Cheng Trang) #6

YES, i post example for DISCOURSE_SMTP_PASSWORD…it’s fake.Tks for remind me.


(Bhanu Sharma) #7

in Your config, the communication Port and TLS support are disabled and that is definitely the reason Your system is unable to identify which port/protocol to use.


(Bhanu Sharma) #8

You need to cross check the port with mailgun that supports TLS and then remove the # in front of these two lines


(Cheng Trang) #9

WOW.The tutorial say remove
DISCOURSE_SMTP_PORT: 465
DISCOURSE_SMTP_ENABLE_START_TLS:

so i commenit it.


(Bhanu Sharma) #10

This isn’t official discourse so I take no responsibility of what they do or say. I have configured mailgun using the official instructions and that has always worked for me so far,


(Bhanu Sharma) #11

Also, adding additional information, make a new sender on mailgun as noreply@(your.domain) and use it’s credentials instead of the default postmaster account.


(Cheng Trang) #12

YES…this is of Discource Switching Your Discourse from Mandrill to Mailgun

But not say config Port.

But i try using port 25 - 465 - 578 then onlly 578 ok!

IT IS WORKING!

Tks you so much itsbhanusharma


(Bhanu Sharma) #13

That is the default startTLS port for SMTP if You do a bit of Googling :wink:

Glad that it’s working finally :slight_smile: