Setting company_domain stops email processing?


(Dirk Jahnke) #1

After setting company_domain as URL to our main web page, no receiving emails have been processed. I expected, that company_domain is used just as a referral to some information, but it seems, it is essential for some functionality. Can someone explain, what company_domain is used for?


(Joshua Rosenfeld) #2

Anything in the email logs?


(Dirk Jahnke) #3

We got following log entry:
SocketError (getaddrinfo: Name or service not known) /usr/local/lib/ruby/2.3.0/net/pop.rb:545:in `initialize’


(Joshua Rosenfeld) #4

I can’t help there. Perhaps @mpalmer has some ideas…


(Matt Palmer) #5

The issue is unrelated to your setting for company_domain. The FQDN you have set for pop3_polling_host is incorrect.


(Dirk Jahnke) #6

Thank you for this clearification. This is as well what I would have expected. And now, after rethinking what happened, I am not sure if we changed that to check if it solves the problem.

Fact is, occasionally the processing of our received mails stops. See also Email processing stopped after getting: incompatible character encodings: UTF-8 and ASCII-8BIT.

But this time, we observed, that after changing the three configuration fields regarding company (short name, full name, domain), email processing stopped. Even restarting the container did not help anymore. We tried to find out the reason until we saw, that processing stopped after changing the company configuration. We reset that, restarted the container again and everything worked fine. Sure, this could be coincidence as well.

For that reason, we just wanted to understand, what the company configuration attributes are used for.


(RĂ©gis Hanol) #7

Without full logs, there’s not much we can do.


(Dirk Jahnke) #8

After setting the company attributes again, no problem occured, which supports your expectation that it is not causing the problems we have.

Is there anything we could do to get more infos in case the email processing stops working again?