Setting LANG: ru_RU.UTF-8 in app.yml does not work when bootstrapping docker container


(Anton) #1

Tried:

LANG: ru_RU.UTF-8
LANG: ru_RU.utf8

Every time I destroy the container, remove the database and try to bootstrap it from scratch, I see the same error:

initdb: invalid locale name ""
locale: Cannot set LC_MESSAGES to default locale: No such file or directory

The database cluster will be initialized with locale “C”.
The default database encoding has accordingly been set to “SQL_ASCII”.
The default text search configuration will be set to “english”.

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "ru_RU.utf8"
are supported and installed on your system.


Removing the existing container and database with the following commands:

./launcher destroy app
cd shared/standalone
rm -rf postgres_data

Initial locale setting now available
(Anton) #2

@sam I remember you was tackling this some time in the past. Would you be so kind to look into it when you get a chance - setting locale in app.yml does not work. Thanks

More details: