# Erro TCP do Sidekiq resolvido usando a porta 587 (não 25)

**URL:** <https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275>\
**Category:** Self-hosting\
**Created:** [Novembro 11, 2022, 4:38am UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275 "2022-11-11T04:38:32Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![spectre](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/spectre/32/274073_2.png) [@spectre](https://meta.discourse.org/u/spectre)\
**Post date:** [Novembro 11, 2022, 4:38am UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/1 "2022-11-11T04:38:32Z")

</div>

\u003e Jobs::HandledExceptionWrapper: Wrapped Net::OpenTimeout: Tempo limite para abrir conexão TCP com [smtp.mailersend.net:25](http://smtp.mailersend.net:25) (excede 5 segundos)

Estou recebendo este erro… Isso significa que preciso abrir a porta 25 para o SMTP funcionar??

---

<div class="post-metadata">

**Author:** ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Post date:** [Novembro 11, 2022, 12:18pm UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/2 "2022-11-11T12:18:20Z")

</div>

Sim. Ele está tentando enviar e-mails e muitos serviços de hospedagem bloqueiam a porta 25 de saída.

---

<div class="post-metadata">

**Author:** ![spectre](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/spectre/32/274073_2.png) [@spectre](https://meta.discourse.org/u/spectre)\
**Post date:** [Novembro 12, 2022, 5:58am UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/3 "2022-11-12T05:58:03Z")

</div>

Eu já permiti a porta 25 no IPtables para aceitar conexões… salvei e fiz com que reinicie toda vez que o servidor reinicia ou é reiniciado! O que mais poderia haver??

Também verifiquei minhas credenciais SMTP… e elas estão boas para usar com meu DNS configurado e tudo mais, mas ainda nada está acontecendo.

Alguma ideia do que está acontecendo aqui?? 🙇‍♂️

---

<div class="post-metadata">

**Author:** ![Jagster](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jagster/32/192154_2.png) [@Jagster](https://meta.discourse.org/u/Jagster)\
**Post date:** [Novembro 12, 2022, 8:20am UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/4 "2022-11-12T08:20:46Z")

</div>

Não sei o que está acontecendo. Mas se você estivesse no DigitalOcean, não importaria se você abriu a porta 25 porque o DO a bloqueia entre você e o mundo.

---

<div class="post-metadata">

**Author:** ![spectre](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/spectre/32/274073_2.png) [@spectre](https://meta.discourse.org/u/spectre)\
**Post date:** [Novembro 12, 2022, 8:54am UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/5 "2022-11-12T08:54:40Z")

</div>

@Jakke Estou com a OVH há tanto tempo e nunca tive problemas com eles, mas há alguns dias comprei um novo servidor deles e o configurei imediatamente com o poderoso sistema iptables deles em vez do ufw tradicional que eu usava até alguns dias atrás e, é claro, abri as portas 22, 80, 443, 6379 e algumas horas atrás 25, mas nada está mudando até agora 🧑‍💻

Estou imaginando que talvez eu precise reiniciar meu(s) sistema(s) servidor e o discourse também, talvez!

---

<div class="post-metadata">

**Author:** ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Post date:** [Novembro 12, 2022, 10:46am UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/6 "2022-11-12T10:46:10Z")

</div>

Pergunte se eles estão bloqueando a porta 25. Se provavelmente estiver sendo bloqueada no roteador, não no sistema operacional. Serviços como o Mailgun usam a porta 2525 para evitar esse problema.

---

<div class="post-metadata">

**Author:** ![Jagster](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jagster/32/192154_2.png) [@Jagster](https://meta.discourse.org/u/Jagster)\
**Post date:** [Novembro 12, 2022, 10:50am UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/7 "2022-11-12T10:50:05Z")

</div>

UFW é apenas um frontend para iptables, que é apenas um frontend para controle de pacotes.

Usar iptables diretamente oferece mais flexibilidade do que UFW, mas precisa de ipatables-persistent. Mas usando iptables vs. UFW não há grandes diferenças, exceto duas:

- com iptable a ordem importa
- com iptable a sintaxe importa

Eu até diria que a menção de iptables não é suficiente quando ninguém sabe o que você tem lá.

Há também um pequeno detalhe. O Docker simplesmente não se importa com o que você fez com o iptables do VPS. O Docker meio que o ignora.

Há apenas uma coisa que eu não entendo: por que você está usando a porta 22?

---

<div class="post-metadata">

**Author:** ![spectre](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/spectre/32/274073_2.png) [@spectre](https://meta.discourse.org/u/spectre)\
**Post date:** [Novembro 12, 2022, 12:20pm UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/8 "2022-11-12T12:20:47Z")

</div>

> [@Jagster](#):
>
> Só há uma coisa que não entendo: por que você está usando a porta 22?

Para conexão SSH ao servidor para instalar plugins e etc 🙂

Dito isso, eu ia mudar essa porta padrão **22** para outro número..!

> [@pfaffman](#):
>
> Pergunte a eles se eles estão bloqueando a porta 25

Boa ideia, mas é fim de semana e eles tendem a dormir até tarde 😃

---

<div class="post-metadata">

**Author:** ![Jagster](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jagster/32/192154_2.png) [@Jagster](https://meta.discourse.org/u/Jagster)\
**Post date:** [Novembro 12, 2022, 12:41pm UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/9 "2022-11-12T12:41:00Z")

</div>

> [@spectre](#):
>
> Para conexão ssh ao servidor para instalar plugins e etc.

Claro. Por favor — não leia o que estou escrevendo, mas o que eu deveria escrever 🤣

Sim. Erro meu. O que eu quis dizer foi por que você quer usar a porta 25…

---

<div class="post-metadata">

**Author:** ![spectre](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/spectre/32/274073_2.png) [@spectre](https://meta.discourse.org/u/spectre)\
**Post date:** [Novembro 12, 2022, 9:33pm UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/10 "2022-11-12T21:33:01Z")

</div>

> [@spectre](#):
>
> Jobs::HandledExceptionWrapper: Wrapped Net::OpenTimeout: Tempo limite para abrir conexão TCP com [smtp.mailersend.net:25](http://smtp.mailersend.net:25) (excede 5 segundos)

Esta é a questão original que estou enfrentando em minha primeira postagem e não sabia o que significava aquele número 25, mas adivinhei que era o número da porta com o envio de e-mails ou confirmação de e-mail para ser mais persistente e estava certo 🙂

> [@Jagster](#):
>
> Sim. Minha culpa. O que eu quis dizer foi por que você quer usar a porta 25

Eu respondi a você com a porta 25?? Não tenho certeza de onde veio, mas aparentemente está lá 😕

---

<div class="post-metadata">

**Author:** ![RGJ](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rgj/32/523185_2.png) [@RGJ](https://meta.discourse.org/u/RGJ)\
**Post date:** [Novembro 13, 2022, 6:59am UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/11 "2022-11-13T06:59:10Z")

</div>

Com o iptables / ufw, você tende a bloquear o tráfego de entrada, mas o erro é sobre o tráfego de saída do seu servidor para o [mailersend.net](http://mailersend.net).

Mas esse não é o seu problema.

A porta 25 não está sendo usada para _retransmitir_ e-mails (em oposição a entregá-los) hoje em dia. Em vez disso, a maioria dos serviços de e-mail usa a porta 587 e, quando pesquiso a documentação do mailersend, ela realmente diz para usar a porta 587, não a porta 25.

---

<div class="post-metadata">

**Author:** ![spectre](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/spectre/32/274073_2.png) [@spectre](https://meta.discourse.org/u/spectre)\
**Post date:** [Novembro 13, 2022, 9:58pm UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/12 "2022-11-13T21:58:08Z")

</div>

Tive esta resposta do suporte do MailerSend;

> Parece que você está usando a porta 25 _**"[smtp.mailersend.net:25](http://smtp.mailersend.net:25)"**_, daí o erro. No momento, suportamos apenas a porta 587 com criptografia TLS.

A porta **25** era a porta padrão nas credenciais de configuração. Mas mudei imediatamente para **587** e as coisas estão super tranquilas agora 🥳

Problema RESOLVIDO

---

<div class="post-metadata">

**Author:** ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)\
**Post date:** [Dezembro 13, 2022, 9:58pm UTC](https://meta.discourse.org/t/sidekiq-tcp-error-solved-by-using-port-587-not-25/245275/13 "2022-12-13T21:58:20Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
