Sign up link shows wrong base_url


(Sree Harsha) #1

I setup discourse from beginning using the Digital ocean one time installer.
While inviting users, the link which is being sent has the wrong URL.
For the same I am trying to find out where the “base_url” values are set, as I seem to have given it wrongly and all the signup mails are going with the wrong email id. Anyway we can correct the base_url from front end?


(Jay Pfaffman) #2

So you didn’t follow these instructions? discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub

You can run ./discourse-setup again to fix it. I think you have to hit control-c to keep it from running its install script again.

cd /var/discourse
./discourse-setup

(Sree Harsha) #3

I went through it again, currently the invite link is showing as “http://forum.kisanmitra.csa-india.org/invites/*************************

Our site is hosted at forum.kisanmitra.org.in, but not sure why base_url is taking forum.kisanmitra.csa-india.org.
How can we change it ?


(Jay Pfaffman) #4

Did you change the hostname when you re-ran discourse-setup?


(Sree Harsha) #5

Yes @pfaffman , did change and rerun, but not much useful. Do suggest if we can change from front end somewhere? As its stalling the process of inviting members and building the community.

Have renamed the community as discuss.kisanmitra.org.in based on feedback.


(Sree Harsha) #6

Tried resetting by running the install script again, but ended up with same …
I still see that url for invite “http://forum.kisanmitra.csa-india.org/invites/54586fc73acbf9df226a5d553bb7c1de” … The correct for the website is http://discuss.kisanmitra.org.in
Pls do let me know where this base_url parameter is stored and how we can get over this …