Signup button should be disabled when using SSO


(Rahul Dhingra) #1

I am using Wordpress SSO plugin and just updated my instance and saw new “sign up” button but the issue is new account credential won’t be recognised by wordpress user DB as a result user won’t be able to sign in with his/her new account. So when using SSO, signup button should be disabled by default.


(Adam Capriola) #2

When you enable the enable sso setting in Discourse it should only show a “Sign In” (or on the latest I think it’s now “Log In”) button.

What “WordPress SSO plugin” are you referring to btw?


(Rahul Dhingra) #3

@AdamCapriola I am referring to the plugin that you created for me Paid one!

Yes i do expect “Sign-up” to disappear when SSO is enabled. but it still appear.


(Adam Capriola) #4

Maybe this will fix it?

https://github.com/discourse/discourse/commit/11e43bd434697d7eca6aa48e3287d79ef2cac0ac


(Rahul Dhingra) #6

@AdamCapriola yes its fixed! and @rubydoob it was spoiler alert

@ moderator Please come and close this thread before this conversation starts becoming Interesting


(Robin Ward) #7

Sorry about that, as pointed out it’s been fixed already.


(Jeff Atwood) #8