Singapore S3 bucket does not work for backups


(Jong Eun Lee) #1

I finished set up s3. (bucket name doesn’t have dot)
but Backup failed with a message when backup.

This fail occur only on specific bucket region.

  • ap-southeast-1 (Singapore) : error
  • us-east-1 : works

How can I fix this problem?

[2014-06-01 07:52:26] Executing the after_create_hook for the backup
[2014-06-01 07:52:38] EXCEPTION: Connection reset by peer (Errno::ECONNRESET)
[2014-06-01 07:52:38] /usr/local/lib/ruby/2.0.0/openssl/buffering.rb:376:in `syswrite_nonblock'
/usr/local/lib/ruby/2.0.0/openssl/buffering.rb:376:in `write_nonblock'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/excon-0.28.0/lib/excon/socket.rb:91:in `write'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/excon-0.28.0/lib/excon/ssl_socket.rb:98:in `write'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/excon-0.28.0/lib/excon/connection.rb:182:in `request_call'

Hot off the presses, automated backup support!
(Kane York) #2

As a first guess, do you have the region set correctly?


(Jong Eun Lee) #3

Yes! Absolutely correct!! But It doesn’t work with ap-southeast-1. :frowning:


(Sam Saffron) #4

Hmm, how can this be our bug? Seems like an issue with Amazon, should it not be raised there?


(Régis Hanol) #5

Can you update to latest and try again? This should be fixed now

https://github.com/discourse/discourse/commit/7658b725568f260b8906b476128368f3354fd47c


(Michael Downey) #6

Awesome, thanks. Currently working on this. The upgrade failed trying to get https://rubygems.org/gems/fog-core-1.22.0.gem. I don’t think that’s related (I’m able to access the file myself) but thought I’d mention it just in case.

Anyway, I’m trying to restart the upgrade, which is going a bit frustratingly, but will let you know how it goes.

After the fix, connection reset errors are gone. Thanks!


(Jeff Atwood) #7

This topic was automatically closed after 3 days. New replies are no longer allowed.