# Site not working after upgrade

**URL:** https://meta.discourse.org/t/site-not-working-after-upgrade/359051
**Category:** Support
**Created:** [March 26, 2025, 11:40pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051 "2025-03-26T23:40:09Z")
**Posts on this page:** 18
**Page:** 1

<div class="post-metadata">

### Author: ![rlauriston](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@rlauriston](https://meta.discourse.org/u/rlauriston)
#### Post date: [March 26, 2025, 11:40pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/1 "2025-03-26T23:40:09Z")

</div>

I did an upgrade. Everything on the admin/update page shows status “Up to date” but when I try to post it fails with “Internal Server Error”.

> **[Food Talk Central](https://www.foodtalkcentral.com/)**
>
> a place for discussions about food

---

<div class="post-metadata">

### Author: ![Arkshine](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/arkshine/32/298682_2.png) [@Arkshine](https://meta.discourse.org/u/Arkshine)
#### Post date: [March 26, 2025, 11:46pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/3 "2025-03-26T23:46:51Z")

</div>

Are you able to post with [safe mode](https://meta.discourse.org/t/53504?silent=true) enabled?  
Do you see any error in the browser’s console?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 26, 2025, 11:55pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/4 "2025-03-26T23:55:10Z")

</div>

Do you have any custom plugins?

---

<div class="post-metadata">

### Author: ![RGJ](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/rgj/32/523185_2.png) [@RGJ](https://meta.discourse.org/u/RGJ)
#### Post date: [March 26, 2025, 11:59pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/5 "2025-03-26T23:59:34Z")

</div>

Your CDN\_URL ends with a slash, you should remove that.  
I’m not sure if this is causing your issue, but it’s certainly not helping.

---

<div class="post-metadata">

### Author: ![rlauriston](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@rlauriston](https://meta.discourse.org/u/rlauriston)
#### Post date: [March 27, 2025, 2:03am UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/6 "2025-03-27T02:03:22Z")

</div>

Same issue in [safe mode](https://meta.discourse.org/t/53504?silent=true). Console:

### Browser Console Mode

Parent process only(Fast)Multiprocess(Slower)

Experiment add-an-image-to-pdf-with-alt-text-rollout has unknown featureId: addAnImageInPDF 3 RemoteSettingsExperimentLoader.sys.mjs:766:21

Uncaught Error: No DOM node set for aPlacesNode. node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]

\_getDOMNodeForPlacesNode chrome://browser/content/places/browserPlacesViews.js:120

nodeTitleChanged chrome://browser/content/places/browserPlacesViews.js:503

18 browserPlacesViews.js:120:13

Uncaught Error: No DOM node set for aPlacesNode. node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]

\_getDOMNodeForPlacesNode chrome://browser/content/places/browserPlacesViews.js:120

nodeMoved chrome://browser/content/places/browserPlacesViews.js:587

browserPlacesViews.js:120:13

Uncaught Error: No DOM node set for aPlacesNode. node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]

\_getDOMNodeForPlacesNode chrome://browser/content/places/browserPlacesViews.js:120

nodeTitleChanged chrome://browser/content/places/browserPlacesViews.js:503

browserPlacesViews.js:120:13

Uncaught Error: No DOM node set for aPlacesNode. node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]

\_getDOMNodeForPlacesNode chrome://browser/content/places/browserPlacesViews.js:120

nodeMoved chrome://browser/content/places/browserPlacesViews.js:587

browserPlacesViews.js:120:13

Uncaught Error: No DOM node set for aPlacesNode. node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]

\_getDOMNodeForPlacesNode chrome://browser/content/places/browserPlacesViews.js:120

nodeTitleChanged chrome://browser/content/places/browserPlacesViews.js:503

2 browserPlacesViews.js:120:13

Uncaught Error: No DOM node set for aPlacesNode. node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]

\_getDOMNodeForPlacesNode chrome://browser/content/places/browserPlacesViews.js:120

nodeMoved chrome://browser/content/places/browserPlacesViews.js:587

2 browserPlacesViews.js:120:13

\_getDOMNodeForPlacesNode chrome://browser/content/places/browserPlacesViews.js:120

nodeMoved chrome://browser/content/places/browserPlacesViews.js:587

Uncaught Error: No DOM node set for aPlacesNode. node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]

\_getDOMNodeForPlacesNode chrome://browser/content/places/browserPlacesViews.js:120

nodeTitleChanged chrome://browser/content/places/browserPlacesViews.js:503

12 browserPlacesViews.js:120:13

Uncaught Error: No DOM node set for aPlacesNode. node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]

\_getDOMNodeForPlacesNode chrome://browser/content/places/browserPlacesViews.js:120

nodeMoved chrome://browser/content/places/browserPlacesViews.js:587

3 browserPlacesViews.js:120:13

---

<div class="post-metadata">

### Author: ![rlauriston](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@rlauriston](https://meta.discourse.org/u/rlauriston)
#### Post date: [March 27, 2025, 2:03am UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/7 "2025-03-27T02:03:47Z")

</div>

No custom plugins I know of so I’m pretty sure no.

> [@RGJ](#):
>
> Your CDN\_URL ends with a slash, you should remove that.

I don’t find a setting for that.

---

<div class="post-metadata">

### Author: ![Arkshine](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/arkshine/32/298682_2.png) [@Arkshine](https://meta.discourse.org/u/Arkshine)
#### Post date: [March 27, 2025, 2:07am UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/8 "2025-03-27T02:07:01Z")

</div>

Can you look at your logs at [https://www.foodtalkcentral.com/logs](https://www.foodtalkcentral.com/logs) and share any relevant errors you see.

---

<div class="post-metadata">

### Author: ![rlauriston](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@rlauriston](https://meta.discourse.org/u/rlauriston)
#### Post date: [March 27, 2025, 2:16am UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/9 "2025-03-27T02:16:01Z")

</div>

Job exception: Net::SMTPAuthenticationError  
Mo 9:50 pm  
Sidekiq heartbeat test failed for 1371476, restarting  
1:11 pm  
Failed to warm up pretty text: terminated /var/www/discourse/lib/discourse\_js\_processor.rb:98:in `eval' /var/www/discourse/lib/discourse_js_processor.rb:98:in `create\_new\_context’ /var/www/discourse/l  
1:11 pm  
3  
Failed to warm up pretty text: terminated /var/www/discourse/lib/discourse\_js\_processor.rb:98:in `eval' /var/www/discourse/lib/discourse_js_processor.rb:98:in `create\_new\_context’ /var/www/discourse/l  
1:12 pm  
5  
MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-City.mmdb) could not be found: No such file or directory @ rb\_sysopen - /var/www/discourse/vendor/data/GeoLite2-City.mmdb  
1:40 pm  
5  
MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-ASN.mmdb) could not be found: No such file or directory @ rb\_sysopen - /var/www/discourse/vendor/data/GeoLite2-ASN.mmdb  
1:40 pm  
3  
MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-City.mmdb) could not be found: No such file or directory @ rb\_sysopen - /var/www/discourse/vendor/data/GeoLite2-City.mmdb  
3:18 pm  
3  
MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-ASN.mmdb) could not be found: No such file or directory @ rb\_sysopen - /var/www/discourse/vendor/data/GeoLite2-ASN.mmdb  
3:18 pm  
Unicorn worker received USR2 signal indicating it is about to timeout, dumping backtrace for main thread config/unicorn.conf.rb:203:in `backtrace' config/unicorn.conf.rb:203:in `block (2 levels) in re  
4:22 pm  
4  
Failed to warm up pretty text: No such file or directory @ rb\_sysopen - /var/www/discourse/lib/emoji/db.json /var/www/discourse/app/models/emoji.rb:154:in `initialize' /var/www/discourse/app/models/em 4:26 pm 2 Errno::ENOENT (No such file or directory @ rb_sysopen - /var/www/discourse/lib/emoji/db.json) app/models/emoji.rb:154:in `initialize’ app/models/emoji.rb:154:in `open' app/models/emoji.rb:154:in `db’  
4:38 pm  
2  
MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-City.mmdb) could not be found: No such file or directory @ rb\_sysopen - /var/www/discourse/vendor/data/GeoLite2-City.mmdb  
4:41 pm  
2  
MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-ASN.mmdb) could not be found: No such file or directory @ rb\_sysopen - /var/www/discourse/vendor/data/GeoLite2-ASN.mmdb  
4:41 pm  
MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-City.mmdb) could not be found: No such file or directory @ rb\_sysopen - /var/www/discourse/vendor/data/GeoLite2-City.mmdb  
4:41 pm  
MaxMindDB (/var/www/discourse/vendor/data/GeoLite2-ASN.mmdb) could not be found: No such file or directory @ rb\_sysopen - /var/www/discourse/vendor/data/GeoLite2-ASN.mmdb  
4:41 pm  
4  
Errno::ENOENT (No such file or directory @ rb\_sysopen - /var/www/discourse/lib/emoji/db.json) app/models/emoji.rb:154:in `initialize' app/models/emoji.rb:154:in `open’ app/models/emoji.rb:154:in `db' 5:08 pm 94 Job exception: hostname ".rest.akismet.com" does not match the server certificate (OpenSSL::SSL::SSLError) 5:42 pm 18 Errno::ENOENT (No such file or directory @ rb_sysopen - /var/www/discourse/lib/emoji/db.json) app/models/emoji.rb:154:in `initialize’ app/models/emoji.rb:154:in `open' app/models/emoji.rb:154:in `db’  
6:27 pm  
2  
Errno::ENOENT (No such file or directory @ rb\_sysopen - /var/www/discourse/lib/emoji/db.json) app/models/emoji.rb:154:in `initialize' app/models/emoji.rb:154:in `open’ app/models/emoji.rb:154:in `db' 6:27 pm 9 Job exception: unknown attribute 'writing_device' for PostStat. 6:29 pm 7 Errno::ENOENT (No such file or directory @ rb_sysopen - /var/www/discourse/lib/emoji/db.json) app/models/emoji.rb:154:in `initialize’ app/models/emoji.rb:154:in `open' app/models/emoji.rb:154:in `db’  
6:52 pm  
6  
ActionView::Template::Error (No such file or directory @ rb\_sysopen - /var/www/discourse/lib/emoji/db.json) app/models/emoji.rb:154:in `initialize' app/models/emoji.rb:154:in `open’ app/models/emoji.r  
6:57 pm  
8  
Errno::ENOENT (No such file or directory @ rb\_sysopen - /var/www/discourse/lib/emoji/db.json) app/models/emoji.rb:154:in `initialize' app/models/emoji.rb:154:in `open’ app/models/emoji.rb:154:in `db' 7:02 pm 48 Errno::ENOENT (No such file or directory @ rb_sysopen - /var/www/discourse/lib/emoji/db.json) app/models/emoji.rb:154:in `initialize’ app/models/emoji.rb:154:in `open' app/models/emoji.rb:154:in `db’  
7:10 pm  
108  
ActionView::Template::Error (No such file or directory @ rb\_sysopen - /var/www/discourse/lib/emoji/db.json) app/models/emoji.rb:154:in `initialize' app/models/emoji.rb:154:in `open’ app/models/emoji.r  
7:11 pm

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [March 27, 2025, 2:53am UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/10 "2025-03-27T02:53:13Z")

</div>

Have you rebuilt this from console?

```plaintext
./launcher rebuild app

```

---

<div class="post-metadata">

### Author: ![rlauriston](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@rlauriston](https://meta.discourse.org/u/rlauriston)
#### Post date: [March 27, 2025, 5:12pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/12 "2025-03-27T17:12:48Z")

</div>

```plaintext
root@www:/var/discourse# ./launcher rebuild app
WARNING: Docker version 24.0.2 deprecated, recommend upgrade to 24.0.7 or newer.
x86_64 arch detected.
ERROR: containers/app.yml does not exist or is not readable.

Available configs ( data, mail-receiver, web_only )
root@www:/var/discourse# 

```

---

<div class="post-metadata">

### Author: ![dubwoc](https://avatars.discourse-cdn.com/v4/letter/d/b4bc9f/32.png) [@dubwoc](https://meta.discourse.org/u/dubwoc)
#### Post date: [March 27, 2025, 5:21pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/13 "2025-03-27T17:21:35Z")

</div>

You have a two-container set up and the additional mail-receiver container.

To rebuild the web app portion do the following as root

> ./launcher rebuild web\_only

If that doesn’t error proceed to doing it with the data container

> ./launcher rebuild data

and see where that leaves you.

---

<div class="post-metadata">

### Author: ![rlauriston](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@rlauriston](https://meta.discourse.org/u/rlauriston)
#### Post date: [March 27, 2025, 6:52pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/14 "2025-03-27T18:52:54Z")

</div>

Thanks, that did the trick.

It would be helpful if the one-click upgrade button were disabled for incompatible configurations.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 29, 2025, 10:07pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/15 "2025-03-29T22:07:49Z")

</div>

> [@rlauriston](#):
>
> I don’t find a setting for that.

It’s in your `app.yml`. You should probably check on it there.

---

<div class="post-metadata">

### Author: ![rlauriston](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@rlauriston](https://meta.discourse.org/u/rlauriston)
#### Post date: [March 29, 2025, 10:24pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/16 "2025-03-29T22:24:47Z")

</div>

So when I get an upgrade notice should I run `launcher rebuild web_only`?

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 29, 2025, 11:25pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/17 "2025-03-29T23:25:44Z")

</div>

You can. It sort of removes the advantage of a 2-container install (I’m assuming it’s two container since you mention web\_only).

Here are my instructions: [Managing a two-container instance - Howto - Literate Computing Dashboard](https://dashboard.literatecomputing.com/t/managing-a-two-container-instance/1207)

Also, you need to pay some attention to things so that you notice stuff like [PostgreSQL 15 update](https://meta.discourse.org/t/postgresql-15-update/349515) that requires you to upgrade the data container as well.

---

<div class="post-metadata">

### Author: ![rlauriston](https://avatars.discourse-cdn.com/v4/letter/r/ec9cab/32.png) [@rlauriston](https://meta.discourse.org/u/rlauriston)
#### Post date: [March 31, 2025, 9:48pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/18 "2025-03-31T21:48:11Z")

</div>

You set it up! What are the advantages of two containers? It seems like more work and I don’t know what the payoff is.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [March 31, 2025, 11:02pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/19 "2025-03-31T23:02:22Z")

</div>

The payoff is that you can build a new container while the old one continues to run, so downtime is under a minute.

It also makes it easier to put off the database upgrade while still being able to to upgrade discourse.

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [April 30, 2025, 11:02pm UTC](https://meta.discourse.org/t/site-not-working-after-upgrade/359051/20 "2025-04-30T23:02:31Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
