SMTP, Exchange Server problem

email
docker

(Hendrik Weiler) #1

Hi,

ive tried to install a discourse instance using docker.

It works so far that i got everything working except the mailing.

Im trying to use an exchange server account for sending mails.
But i always get

504 5.7.4 Unrecognized authentication type

when i try to test it inside of the admin panel.

My settings:

address	192.168.0.114
port	39
user_name	user
authentication	plain
enable_starttls_auto	false

I found this link Troubleshooting email on a new Discourse install
and tried to set the notification_email to the email adress of the email user with, since its required to send an email via exchange server:

./launcher enter app
rails r "SiteSetting.notification_email = 'discourse@yoursite.com'"
exit

But all i get always:

/usr/local/bin/rails: line 3: [: too many arguments

Im using 1.3.0.beta5

I dont know what im missing to get it working.


(Jens Maier) #2

For starters, I’m not sure why rails r isn’t working, but please try if an error occurs with

./launcher enter app
rails c
SiteSetting.notification_email = 'discourse@yoursite.com'
exit
exit

Regarding the mailserver problem, are you certain that the mailserver allows authentication over unencrypted connections? If enabling STARTTLS or setting DISCOURSE_SMTP_AUTHENTICATION: login doesn’t help, you will have to ask your mail server’s administrator for assistance.


(Hendrik Weiler) #3

Thank you @elberet.

Doing it with

rails c

was working and using

DISCOURSE_SMTP_AUTHENTICATION: login

solved my problem.