Software won't display uploaded avatar?


#1

I have a rather odd problem that I want to ask if anyone has encountered.

I recently updated the software from 2.02 to 2.03, and switched from file upload from s3 to local server.

And when I updated my own avatar, I was able to upload it,

and save, but the software doesn’t display the actual avatar, just the generic grey person icon.

SNAG-0004

Any idea what may be causing this oddity? I tried turning s3 back on, but the problem persists.

Thanks.


(Sam Saffron) #2

This is got to be related to your s3 move, can you amend 1 pixel in your avatar and retry?


#3

I have tried 2 things just now:

  1. Amend and upload (to local).
  2. turn on s3, refresh browser window, amend, and upload (to s3)

So odd.


(Sam Saffron) #4

Have you had a look in /logs for any errors?


#5

No error in log.

I updated the software from 2.0.3 to 2.1.0.beta3, and the avatar I uploaded when I was at 2.0.3 displayed.


(Régis Hanol) #6

Turning on/off S3 is not something to be done slightly. Even though we’ve tried to automatize most of it, it’s a tedious process.

For example, did you run the uploads:migrate_from_s3 rake task after disabling S3?


(Bhanu Sharma) #7

That task isn’t working properly as far as I know.


(Régis Hanol) #8

Well, if it’s broken, we need to fix it.

What’s not working?


(Bhanu Sharma) #9

The attachments don’t get downloaded though the script returns success!

And then, even after the rebake task, urls don’t get replaced and are still served from bucket.

Recently me and another user tried to migrate from s3 to local and as far as I know, we both failed.

More details with @vinothkannans

Here is my topic.

Other discussion:


(Vinoth Kannan) #10

I think migrate_from_s3 take task is not working for our new image upload URL format upload://kDCWDmRdbg2AkLIcq40Nk1k.jpg


#11

a fix would be great, as its costing me money rn and affecting others


(Régis Hanol) #12

Ok, I’ve fixed the rake task to support short urls :peach:

@ckshen, @itsbhanusharma & @pain you might want to update to the latest version and try again :wink:


(Bhanu Sharma) #13

I’ll give it a shot this weekend. Thanks :tanabata_tree:


#14

it’s still loading from aws,
i ran

rake posts:rebake
rebuilt app and still not loading locally

also,
i dont know if this is helpful but some images have ![image|281x499] at the end (some dont)
(upload://82m8NdfumiLKt30PRErbHBgirPT.jpeg)![image|281x499]
image


#15

To clarify, each ! signifies a new image from a syntax perspective.

You said it’s loading from aws, and also locally. Wouldn’t locally means the migration completed successfully?

One more question, did you run the rake task for rebake only? Or did you also run the s3 migrate rake task? You need the latter.


#16

i meant “not loading locally”, typo,
also, i ran migrate task then rebake


(Bhanu Sharma) #17

So that means it’s still not working?

Or do we have to remap urls manually?


(Régis Hanol) #20

Thanks to @pain I was able to test the migrate task on real data and fixed a mistake I made :blush:


(system) #21

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.