# \[Solved\]Bootstrap fails, Postgres already running

**URL:** https://meta.discourse.org/t/solved-bootstrap-fails-postgres-already-running/20041
**Category:** Self-hosting
**Created:** [September 13, 2014, 8:24pm UTC](https://meta.discourse.org/t/solved-bootstrap-fails-postgres-already-running/20041 "2014-09-13T20:24:15Z")
**Posts on this page:** 1
**Showing post:** 19

<div class="post-metadata">

### Author: ![Dwalus](https://avatars.discourse-cdn.com/v4/letter/d/87869e/32.png) [@Dwalus](https://meta.discourse.org/u/Dwalus)
#### Post date: [March 29, 2015, 11:01pm UTC](https://meta.discourse.org/t/solved-bootstrap-fails-postgres-already-running/20041/19 "2015-03-29T23:01:07Z")

</div>

@sam okay, and then I try launching? I’m still failing to bootstrap.

```
root@maps:/var/discourse# ./launcher bootstrap app
cd /pups && git pull && /pups/bin/pups --stdin
From https://github.com/SamSaffron/pups
   ee8fdfb..4203610 master -> origin/master
Updating ee8fdfb..4203610
Fast-forward
 README.md | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)
I, [2015-03-29T22:59:46.227700 #41] INFO -- : Loading --stdin
I, [2015-03-29T22:59:46.242309 #41] INFO -- : > mkdir -p /shared/postgres_run
I, [2015-03-29T22:59:46.248445 #41] INFO -- : 
I, [2015-03-29T22:59:46.250250 #41] INFO -- : > chown postgres:postgres /shared/postgres_run
I, [2015-03-29T22:59:46.254719 #41] INFO -- : 
I, [2015-03-29T22:59:46.256305 #41] INFO -- : > chmod 775 /shared/postgres_run
I, [2015-03-29T22:59:46.262436 #41] INFO -- : 
I, [2015-03-29T22:59:46.263948 #41] INFO -- : > rm -fr /var/run/postgresql
I, [2015-03-29T22:59:46.269209 #41] INFO -- : 
I, [2015-03-29T22:59:46.270759 #41] INFO -- : > ln -s /shared/postgres_run /var/run/postgresql
I, [2015-03-29T22:59:46.274267 #41] INFO -- : 
I, [2015-03-29T22:59:46.275702 #41] INFO -- : > socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1
I, [2015-03-29T22:59:46.304313 #41] INFO -- : postgres already running stop container

FAILED
--------------------
RuntimeError: socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1 failed with return #<Process::Status: pid 48 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params "socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1"
70642f4f8aed7b087435e19837ae83a11b3a562dabe51e43ebf0c8bd2d462221
FAILED TO BOOTSTRAP

```

---

_[View the full topic](https://meta.discourse.org/t/solved-bootstrap-fails-postgres-already-running/20041)._
