Solved Button plugin does not work?


(Ray) #1

I’ve recently added the Solved-Button plugin but I’m not seeing the “Allow users to accept answers” checkbox.


Discourse Solved (Accepted answer plugin)
(Jay Pfaffman) #2

You need to enable it in each category that you want to use it in. There is also a system setting to enable it globally.


(Ray) #3

Hi Jay,
When I attempt to edit the settings in one of my categories, I don’t see the option.

This is what I’m seeing:


(Daniela) #4

Hi @rayk, could you confirm that the site setting allow solved on all topics is not enabled, please?


(Ray) #5

i can’t find that option under settings… where should that be?


(Daniela) #6

Search for solved in your site setting (your-site.com/admin/site_settings/category/required):

Do you have my same results?


(Ray) #7

getting “no results found”


(Daniela) #8

So it seems that the plugin has not been installed, can you check here /admin/plugins if you see it?
If the answer is no, you must first check your app.yml file to see if it is in the list of installed plugins

hooks:
  after_code:
    - exec:
        cd: $home/plugins
        cmd:
          - mkdir -p plugins
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discourse/discourse-solved.git

(Ray) #9

ahh, i was using a different plugin:

i’ll use the discourse-solved.git instead…


(Daniela) #10

In addition to not being the #official one, that plugin is also very old and has never been updated (last commit 4 years ago) :no_mouth:.
You were lucky that you have not broken the site by installing it. Be sure to always check here on Meta before installing something. It is possible that if a plugin has some problem, someone has already reported it.


(Ray) #11

Thanks Daniela! All good now.


(Павел Кульков) #12

Hi!
I have the same problem, but plugin installed. I see it in /admin/plugins


(Павел Кульков) #13

After clear cache and relogin its ok now.