[SOLVED] Errors loading avatars with HTTPS enabled


(Ars Artificia) #1

Hi all,
this is my site : discourse.ars-artificia.com
and I get broken images for avatars, pretty similar to this topic:
Avatars not always showing up after refresh
So I made sure everything is up-to-date (nginx version 1.7.10 mainline), but I still get the same error.

In addition to that I don’t get the exact same error. I get a “HTTP/1.1 503 Service Temporarily Unavailable” error.

Reloading sometimes fixes it, sometimes it does not. The issues started after I enabled SSL and I assume they got worse after I configured nginx with PFS. (Just assumptions though).

I have the ssl option in discourse enabled, but disabled it for testing some time as well.

Looking forward to any help.
Thanks


(Jeff Atwood) #2

Not the same issue. You likely have a configuration problem of some kind, we have lots of https sites and no issues loading avatars.


(Ars Artificia) #3

Yeah, thanks for clarification, I was already pretty positive it was not the same problem, but the “symptomes” are (at least optical) the same.
Any idea what kind of configuration might be the problem ?


(Ars Artificia) #4

Everything nice and easy, working perfectly soomth now with Discourse 1.2.0.beta9 !


(Régis Hanol) #5