# Something seems to have gone wrong with my update

**URL:** <https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952>\
**Category:** Self-hosting\
**Created:** [January 18, 2017, 8:08am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952 "2017-01-18T08:08:11Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![peternlewis](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/peternlewis/32/108888_2.png) [@peternlewis](https://meta.discourse.org/u/peternlewis)\
**Post date:** [January 18, 2017, 8:08am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/1 "2017-01-18T08:08:11Z")

</div>

Something seems to have failed with my update to 1.7.x ([https://forum.keyboardmaestro.com/](https://forum.keyboardmaestro.com/)).

Nothing is showing up and I’m getting errors like:

 ![](https://global.discourse-cdn.com/meta/original/3X/7/9/79287582051cc009de6087e1bf4c99395d6b1dd2.png)

I’m wondering if the update failed part way through.

Any suggestions on how to get it going again?

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [January 18, 2017, 8:12am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/2 "2017-01-18T08:12:03Z")

</div>

Have you tried [safe mode](https://meta.discourse.org/t/53504?silent=true)? Any incompatible plugins can break you.

---

<div class="post-metadata">

**Author:** ![peternlewis](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/peternlewis/32/108888_2.png) [@peternlewis](https://meta.discourse.org/u/peternlewis)\
**Post date:** [January 18, 2017, 8:31am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/3 "2017-01-18T08:31:28Z")

</div>

No safe-mode does not do any better. It asks me if I want [safe mode](https://meta.discourse.org/t/53504?silent=true) and I say yes I still get the same result. Nothing shows up at all

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [January 18, 2017, 8:32am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/4 "2017-01-18T08:32:14Z")

</div>

Try rebuilding again from the command line. If you are using any third party plugins, remove them before rebuilding.

---

<div class="post-metadata">

**Author:** ![peternlewis](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/peternlewis/32/108888_2.png) [@peternlewis](https://meta.discourse.org/u/peternlewis)\
**Post date:** [January 18, 2017, 8:41am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/5 "2017-01-18T08:41:46Z")

</div>

Would that be:

```plaintext
cd /var/discourse
./launcher rebuild app

```

Will that update any files if they are not up to date?

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [January 18, 2017, 8:42am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/6 "2017-01-18T08:42:50Z")

</div>

Yes, give that a shot, but be sure to remove any third party plugins from the app.yml first.

---

<div class="post-metadata">

**Author:** ![peternlewis](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/peternlewis/32/108888_2.png) [@peternlewis](https://meta.discourse.org/u/peternlewis)\
**Post date:** [January 18, 2017, 9:42am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/7 "2017-01-18T09:42:56Z")

</div>

I disabled solved and tags

```plaintext
# - git clone https://github.com/discourse/discourse-tagging.git
# - git clone https://github.com/discourse/discourse-solved.git

```

but I get this error when rebuilding:

```plaintext
root@forum:/var/discourse# ./launcher rebuild app
Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
Stopping old container
+ /usr/bin/docker stop -t 10 app
app
cd /pups && git pull && /pups/bin/pups --stdin
Already up-to-date.
I, [2017-01-18T09:41:34.458117 #13] INFO -- : Loading --stdin
I, [2017-01-18T09:41:34.466939 #13] INFO -- : > echo cron is now included in base image, remove from templates
I, [2017-01-18T09:41:34.470539 #13] INFO -- : cron is now included in base image, remove from templates

I, [2017-01-18T09:41:34.470814 #13] INFO -- : > apt-get remove -y postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5
E: Sub-process /usr/bin/dpkg returned an error code (1)
I, [2017-01-18T09:41:37.110594 #13] INFO -- : Reading package lists...
Building dependency tree...
Reading state information...
The following packages will be REMOVED:
  postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
After this operation, 26.1 MB disk space will be freed.
(Reading database ... 34533 files and directories currently installed.)
Removing postgresql-contrib-9.5 (9.5.5-1.pgdg16.04+1) ...
update-alternatives: warning: forcing reinstallation of alternative /usr/share/postgresql/9.5/man/man1/postmaster.1.gz because link group postmaster.1.gz is broken
update-alternatives: error: error creating symbolic link '/usr/share/man/man1/postmaster.1.gz.dpkg-tmp': No such file or directory
dpkg: error processing package postgresql-contrib-9.5 (--remove):
 subprocess installed pre-removal script returned error exit status 2
dpkg: postgresql-9.5: dependency problems, but removing anyway as you requested:
 postgresql-contrib-9.5 depends on postgresql-9.5 (= 9.5.5-1.pgdg16.04+1).

Removing postgresql-9.5 (9.5.5-1.pgdg16.04+1) ...
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of stop.
Removing postgresql-client-9.5 (9.5.5-1.pgdg16.04+1) ...
Processing triggers for postgresql-common (178.pgdg16.04+1) ...
Building PostgreSQL dictionaries from installed myspell/hunspell packages...
Removing obsolete dictionary files:
Errors were encountered while processing:
 postgresql-contrib-9.5

FAILED
--------------------
Pups::ExecError: apt-get remove -y postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5 failed with return #<Process::Status: pid 16 exit 100>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params "apt-get remove -y postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5"
f39c918850fc3105167df6ad93b20c0bdf4678553c6bad4059ebe44016e8d179
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [January 18, 2017, 9:45am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/8 "2017-01-18T09:45:15Z")

</div>

That’s odd. Tagging has been in Discourse as a core feature for a few versions now.

Make sure you add a git pull in there if you were on a very old version:

```plaintext
cd /var/discourse
git pull
./launcher rebuild app

```

---

<div class="post-metadata">

**Author:** ![peternlewis](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/peternlewis/32/108888_2.png) [@peternlewis](https://meta.discourse.org/u/peternlewis)\
**Post date:** [January 18, 2017, 9:45am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/9 "2017-01-18T09:45:52Z")

</div>

I was on 1.6.x (the latest before 1.7 I believe).

I’ll try.

---

<div class="post-metadata">

**Author:** ![peternlewis](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/peternlewis/32/108888_2.png) [@peternlewis](https://meta.discourse.org/u/peternlewis)\
**Post date:** [January 18, 2017, 9:46am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/10 "2017-01-18T09:46:16Z")

</div>

Nope:

```plaintext
root@forum:/var/discourse# git pull
Already up-to-date.

```

---

<div class="post-metadata">

**Author:** ![peternlewis](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/peternlewis/32/108888_2.png) [@peternlewis](https://meta.discourse.org/u/peternlewis)\
**Post date:** [January 18, 2017, 9:51am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/11 "2017-01-18T09:51:30Z")

</div>

Should I enter the docker container and then try:

```plaintext
apt-get update

```

?

---

<div class="post-metadata">

**Author:** ![peternlewis](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/peternlewis/32/108888_2.png) [@peternlewis](https://meta.discourse.org/u/peternlewis)\
**Post date:** [January 18, 2017, 10:10am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/12 "2017-01-18T10:10:31Z")

</div>

What is supposed to be going on with postgresql?

The error reports

```plaintext
The following packages will be REMOVED:
  postgresql-9.5 postgresql-client-9.5 postgresql-contrib-9.5

```

But if I do apt-get update to see what it wants to do, it wants to install postgresql-9.3 postgresql-client-9.3 postgresql-contrib-9.3

So which version is supposed to be installed? Why would 9.5 be installed already and why would it want to remove it when upgrade wants to install 9.3?

---

<div class="post-metadata">

**Author:** ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)\
**Post date:** [January 18, 2017, 10:29am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/13 "2017-01-18T10:29:54Z")

</div>

We updated our docker image to Postgres 9.5 back in May 2016

[https://meta.discourse.org/t/discourse-docker-image-version-1-3-3-released/44778](https://meta.discourse.org/t/discourse-docker-image-version-1-3-3-released/44778)

---

<div class="post-metadata">

**Author:** ![peternlewis](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/peternlewis/32/108888_2.png) [@peternlewis](https://meta.discourse.org/u/peternlewis)\
**Post date:** [January 18, 2017, 10:40am UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/14 "2017-01-18T10:40:55Z")

</div>

OK, my app.xml was still saying postgres 5.3. I changed it to just postgres and the rebuild worked and I am back up and running.

Thanks for your assistance!

Now I should be able to reenable the solved plugin.

I presumably don’t need to reenable the tags plugin as you say.

---

<div class="post-metadata">

**Author:** ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)\
**Post date:** [June 8, 2024, 12:45pm UTC](https://meta.discourse.org/t/something-seems-to-have-gone-wrong-with-my-update/55952/15 "2024-06-08T12:45:02Z")

</div>

This topic was automatically closed after 2698 days. New replies are no longer allowed.
