Sorry, there was an error authorizing your account. Perhaps you did not approve authorization? Error


(Aaryan Khurana) #1

I read this thread.
And according to it, I enable Google+ API and Google+ Domain API but it is still not working.
Please help.


(Stephen) #2

Is your app key/secret from Google set correctly here:

https://discourse.example.com/admin/site_settings/category/login

If so that should only happen if you click deny when the Google auth pops up. Was it a Gmail or gsuite account?

Can you confirm if your install is http or https? I’m assuming you’ve set up an FQDN rather than trying to install against an IP address?

Do you have more than one project configured on the Google developer portal? If you’ve multiple make sure you’ve enabled the Google+ API and domains API against the right project.


(Aaryan Khurana) #3

Everything you mentioned above is set correctly.
The only thing that I think seems weird is, it is not showing auth pop up with allow or deny option.
It asks to type email and password in newly created window in browser. Even if I am already logged in using multiple google accounts, it doesn’t ask me to choose one from those(i have mentioned select_account in settings) , instead it show blank space to type email followed by same thing for password, and it throws error before showing auth pop-up (screen with allow and deny button).


(Stephen) #4

Ok, and with the same browser configuration you’re able to log into other google-login enabled discourse instances?


(Aaryan Khurana) #5

Yes. To write this response I am using same browser.