"Sorry, we couldn’t load that topic, possibly due to a connection problem"


#1

After attempting an update via the admin area, it failed during the final stages due to not having enough memory (2GB instance). The version shown in the /admin/upgrade area did show the latest version after this error however. After this, I also rebooted the instance via SSH. I’ve since flexible resized the instance have 4GB ram for the time being.

There is a topic which gives this error when I click on it:

“Sorry, we couldn’t load that topic, possibly due to a connection problem. Please try again. If the problem persists, let us know.”

If I load the url directly, I get a server error 500. All the other topics I’ve checked seem fine, it’s just this one.


"Cannot load app" for a meta topic
(Sam Saffron) #2

Try rebuilding your container


#3

Thanks Sam, I tried your suggestion of rebuilding the container using:

cd /var/discourse
./launcher rebuild app

The topic is still giving the same error however.


(Sam Saffron) #4

Look in ‘sitename/logs’ what error shows up there when you visit that topic?


#5

One of the users in my discourse site encountered the exact same error,

Issue

  1. Just a single user is affected
  2. He is accessing the site using his mobile
  3. He gets the error when trying to open an existing PM thread.
  4. Everything else works perfectly. He is able to post publicly. He is able to open/reply to other PM threads. Just that he is not able to open that particular PM thread.

Error screenshot
image

Device
Mobile

Error log
It didn’t trigger anything there.

Server Health
CPU/RAM - in good condition.
Server Load - in good condition


(Jeff Atwood) #6

Have this person try a different web browser, or connecting on wifi vs cellular (or vice-versa).


#7

I found another instance when this exact same occurred. This time, I myself noticed it.

Situation
A user created a new thread. It did not have any other posts in it other than the OP’s first post.
After 1-2 min of thread creation, I as an admin deleted this thread.
After 5min, I went to his profile, clicked on “Deleted posts” - because I wanted to un-delete that thread.
Upon clicking on “deleted posts” it showed me all his deleted posts. I am able to check all his past posts except the 2 very recent posts. The most recent post was created 22min ago - I couldn’t view it. When I clicked on it, it showed the error I pasted below. The other post was created on “Nov 8 2017” - this one too I couldn’t view, it showed the same error.

What I think is this

The 2 posts from this user’s “deleted posts” which I couldn’t view or un-delete are “the first post of a thread”. So, at least this time, issue is caused when we delete the first post of a thread. If its any other post, its letting us un-delete it by going to “deleted posts”. But if its the first post of a new thread, then it doesn’t let us un-delete that post. Instead if throws the above error message.


(Mittineague) #8

Did you delete the topic by using the topic admin wrench, or the post using the post delete? It wasn’t deleted from “needs approval” or akismet?


#9

It did not go to “needs approval” because this thread was started by an existing user (with tons of posts in the site already). (I do not have akismet installed either)

It was the first post in that thread, so I just deleted directly by clicking on the “post delete” button which is found just below the post.


(Mittineague) #10

I just now tested two variations. First: Topic created by TL2 Member, deleted during grace period. Second: Topic created by TL2 Member, deleted after grace period.

I could not replicate with this workflow: Single Tab, Delete with post delete, Click avatar to User profile page, Click “deleted posts” (with apology to coulrophobes)

deleted-post


#11

I am able to repro again.

  1. I searched for a thread with just 1 post in it. (I mean a thread with just the initial post and no other posts). Clicked on the delete post button found just below the initial post. After that, I clicked on user’s profile - > deleted posts. There I can see this thread. I clicked on it to open the thread. When I did that, I’m getting this error.

I think this is good, since I’m able to repro it easily.

Now, I’m going to check if any of the plugins that I’ve installed in my site is causing this or is it the discourse core code that is causing it. So, what I’m going to do now is - trying to repro this on a brand new test instance with no plugins installed.


ServiceWorker thinks I'm offline when I'm not
(Michael Brown) #12

Can you check your app tools to see if you’re getting your “Offline” message from the Service Worker?


#13

@supermathie
This is what I see in app tools

And if I refresh the page again (keeping the chrome tools open,) on the left side I see a blank page (there error is no more there), and in app tool logs I see this

For the homepage, I see this

And, for Discourse homepage, I see this