Sorry, we couldn't find that topic


(Ian Purton) #1

Sometimes on my bitcoindiscourse.org site I get the following message.

Sorry, we couldn’t find that topic. Perhaps it has been deleted?

However, if I refresh the page it loads fine. What do you need from me to help debug this ? Thanks.


(Chris Hanel) #2

The topic still has to be mined before it can be displayed, obviously.

Sorry, I’ll see my way out.


(Jeff Atwood) #3

I believe I have seen that when on poor network connections, e.g. the topic essentially fails to load because it times out or gets interrupted. Just a hunch at this point.

But I do recall having that reaction after reloading the page – this topic wasn’t deleted at all, it just failed to load initially for some reason.


(Daniel Watkins) #4

Keeping your browser’s debugger open until it happens and then looking for anything unusual would help.


(Ian Purton) #5

No errors in the web console but the problem occurs quite regularly.

Problem is pretty consistent for me. i.e.

  1. go to http://bitcoindiscourse.com/
  2. Click on any topic
  3. “Couldn’t find that topic” appears almost instantly.

Do other people see this or just me ?


(Alex R) #6

I clicked on 3 topics, and none of them said “Couldn’t find that topic”. Sounds like it’s on your end.


(Luke S) #7

This. My home connection is slow, (dial-up, if you believe it.) and I have had this happen, especially when I have a larger page loading in the background.

So, a server time-out can be mistaken for a ‘Can’t find your post’ message from the back-end? If so, I’d think that you might have a larger incidence of these type of errors once you launch mobile device support.


(Jeff Atwood) #8

Yeah we should definitely look into this. I don’t like the idea that weird timeouts can cause people to think topics were deleted when that is not the case.


(Jeff Atwood) #9

In fact, I just got one of these notices while on WiFi at home… absolutely nothing weird going on. We need to look into this. In the meantime I am changing the message to be a little more generic until then so people don’t think all topics are deleted…

Changing to

description: "Sorry, we couldn't load that topic, possibly due to a connection problem. Please try again. If the problem persists, perhaps the topic was deleted."

for now.


(Ian Purton) #10

I suspect the issue is related to surfing through a corporate firewall.

I’ve just tried another discourse install and I get the same problem. It may be that your are using websockets or something like that ?


(Ian Purton) #11

I've debugged the network traffic for this issue. The problem might be the 403 returned for 1.json ?

[16:33:56.570] GET http://bitcoindiscourse.com/t/46/1.json?track_visit=true [HTTP/1.0 403 Forbidden 1202ms]


(Jeff Atwood) #12

Ok we just deployed a change that shows three distinct, specific topic load error messages rather than the single ambiguous one we had before:

  1. No permissions, eg you tried to load a private message not addressed to you

  2. Not found, eg you tried to load a topic that has been deleted by a moderator

  3. Loading error, eg the client JavaScript got a network error retrieving the topic JSON

That should help diagnose the problem in more detail, hopefully.


(Jeff Atwood) #13

I wish I could close this, but still seeing case #2 sporadically, topics not found that clearly exist. Quite rare and no repro though.


(Jeff Atwood) #14

Have not seen this in a long long time so archiving.


(Jeff Atwood) #15