Specific admin user unable to logout


#1

Users are no longer able to logout of the forum. Clicking the logout button does absolutely nothing – the mouse cursor changes from the arrow to the hand, but clicking logout does not register anything (the drop-down menu does not disappear).

I can replicate the problem on my MAC using Safari and Chrome, and also on my Blackberry using the default browser.

I hadn’t made any changes in the forum Admin CP for a while now, so this issue cropping up is definitely strange.

I just updated to the very latest version (was one update behind) hoping it would fix the problem, but it still persists. I have Discourse installed on DigitalOcean via their one-click installation.

Any ideas?


(Kane York) #2

Try the keyboard shortcut - a capital Z twice.


#3

Thanks for offering to help! Unfortunately, typing ZZ does not log me out.


(Dean Taylor) #4

This actually needs to be Shift+Z, Shift+Z. Using caps lock won’t work.


(Kane York) #5

Okay, then something bigger than just the log out button is broken. Anything in the JS console after you click it?


#6

Hi @DeanMarkTaylor that doesn’t work. I typed shift+Z shift+Z and also tried shift+ZZ. Regardless, I need a real fix to this issue.


(Jeff Atwood) #7

If you are using any third party plugins or customizations, remove them. This is almost certainly your issue.


(Dean Taylor) #8

Does it work for you on http://try.discourse.org ?

If the answer is “yes” the most likely cause is one of the following:

  • A bad plugin, try disabling and removing discourse plugins.
  • A bad customisation - try disabling all the customisation in the admin section.
  • A bad browser plugin - try Chrome in an “incognito” window.

#9

@codinghorror Absolutely no plugins.


(Jeff Atwood) #10

Any “customizations” via Admin, Customize? Particularly JS ones?


#11

This is the CSS I had. I disbled it but the problem still persists, or should I restart Discourse, too?

#user-card .card-content {
  background: rgba(34,34,34,.2);
}

.user-main .has-background .details {
  background: rgba(34,34,34,.2);
}

#12

I can actually logout from the Admin CP, but not from the ‘normal’ logout dropdown link. I can keep clicking it but nothing registers.


(Jeff Atwood) #13

If you can log out here, or on http://try.discourse.org then it is by definition not a bug. Perhaps it is a CSS / HTML issue of some kind?

Just to confirm, I logged out and back in here just fine using the menu as pictured, no problem.


#14

I can logout of this forum no problem. I am the first to admit if i’ve done something that causes a problem, but this issue came right out of left field. I hadn’t been in the Admin CP for at least a few days, and had been logging out without issue until today.

This is simply bizarre.


(Kane York) #15

If you hit F12, then Console, does anything show up when you click logout?


#16

Here’s a screenshot of what happens when I click the Logout link:


#17

Anyone with an idea on how to fix this?


#18

I traced back the last changes I made in the Admin CP:

  • I removed “admin” from the restricted user names list
  • I created a new account with admin as the username, then granted the account admin and mod privs. The reason I did this is because I planned to remove admin and mod privs from my everyday user account in case I lost my phone while logged in to the forum, etc.

Do you think this may have caused this issue? I have tried to reverse it by removing admin and mod privs from this ‘admin’ account but am unable to delete it (no posts were made with the account).

This.Is.So.Frustrating.


#19

OMG I finally managed to delete the ‘admin’ account I created as mentioned in above post, and am now able to logout with my own account and so are other users.

I have no idea what the correlation was, but am glad it has been sorted.


(TechnoBear) #20

Using sticky keys won’t work, either. :frowning: