SSO no longer working


(Melissa Thompson) #1

Hi, today our SSO stopped working to get users logged into Discourse. It’s saying that groups can no longer be found. Has something changed in the Discourse side? This is preventing anyone from using our community.


(Scott Moore) #2

Some more info on this: the group called “everyone” seems to have disappeared. This is our default group for users and gets added when they log in via the SSO.


(Scott Moore) #3

Update: Found this thread, which seems to be related to our issue:

Looks like we got caught up in the hiding of the everyone group. I switched our config over to use trust_level_0 instead of everyone and our SSO is back up now.


(Sam Saffron) #4

Definitely remove everyone from there, its a bug that this ever even worked. @everyone is 100% automatic you do not need to specify that in your SSO payload.

Note, I am unsure how my commit would have broken this, but also I am unsure how it ever even worked in the first place as this group should never ever be touched.