Stackprof gem and Ruby 2.2


(Gerhard Schlager) #1

I’ve created a new dev VM which seems to have installed Ruby 2.2.
https://meta.discourse.org/t/beginners-guide-to-install-discourse-on-ubuntu-for-development/14727/53?u=gerhard&source_topic_id=24376

Anyway, it looks like the stackprof gem isn’t used anymore. I guess it’s because of this TODO:

Can this be changed now?


(Sam Saffron) #2

we can add a conditional that checks bundler to see if its the right version and then include it for 22, I will get around to it once I start hacking with 2.2


(Jeff Atwood) #3

Will we be moving directly to 2.2 @sam? I think that’s the case? We need to measure the increase in memory consumption on a fresh cloud install (or ourselves) to see what the impact is going to be.


(Sam Saffron) #4

stackprof is actually used by the flamegraph gem, which is an extension on top of mini_profiler.

Anyway, the mess of dependency is slightly less messy now that we are explicitly only supporting ruby 2.3