Sudden Increase in Bugs on Discourse Backup System


(sin) #1

Hi,

there just wanted to report something weird I came across lately, been using Discourse for almost 1 year now, without much of issues, in recent two days have came across too many bugs, (more than the whole entire year). And they were all related to the Backup System, Here is a list:

  1. When Restoring from a Backup to a new Install, Discourse Somewhat misses up the Facebook, Google API Login Keys

  2. Today After doing backup, once the backup process reached “notifying user” It hanged there forever, I checked my website and server and Found it went down :fearful: I had to do a hard reboot to bring it back online.
    Here is a little chart showing the CPU usage during the bug:


    When the server crashed it reached 100% usage!!!
    P.S. tried another backup, it didn’t crash this time!
    EDIT:
    The backup file generated during the crash is slightly different in size

  3. After Doing a Backup, and Installing my Own SSL either OpenSSL or something else, I get ERROR_TOO_MANY_REDIRECTS just on a restored website on a fresh install it works just fine

  4. On a restored website the SSL folder under shared, is missing! not sure if that’s normal or not, but in my original installation it was there, and All I had to do is to put new ssl key and crt under it.

That’s all I can remember for now :slight_smile:


(Rafael dos Santos Silva) #2

Was this on the latest 1.8.x version?


(sin) #3

Yep, On the latest version, and on every backup I follow all the instructions, and I use only a fresh copy.


(Rafael dos Santos Silva) #4

:thinking: the second bug was a thing on an old version, but got fixed.


(sin) #5

Then i think the issue should be re-opened I guess :blush: btw, I’ve added more details to the original post.


(Jeff Atwood) #6

I think you have a broken or misconfigured install, based on these items.


(sin) #7

Maybe, but taking into account that I’m using Discourse for almost a year now. on multiple installations. and 3 out of 3 installations that I tried had either one of those issues or multiple issues. Especially around the backup system.