Suddenly uses unconfigured.discourse.org as from address


(Jakob Borg) #1

I recently updated to the latest 1.5.0beta7, which this time included updating /var/discourse from git and rebuilding the container (web; separate from data). Currently, all mail is being sent from noreply@unconfigured.discourse.org. However, the notification email site setting is correct (and not unconfigured.discourse.org), so I’m not sure where this may be coming from? It was working correctly prior to the upgrade, but I’m not sure what container version was running at that time…


Edit; So, resetting the notification email setting to the default, and then setting and saving it again seems to have resolved this. However that’s a bit scary?


(Wes Osborn) #2

I just saw this happen as well on my install. It happened this morning and doesn’t appear to be directly related to any upgrade actively (we upgraded to v1.9.0.beta2 +83, but it was a couple of weeks ago). I’m going to try resetting the notification email and see if that works for us.


(Jeff Atwood) #3

This still exists in site_settings.yml

  notification_email:
    default: 'noreply@unconfigured.discourse.org'
    type: email
    shadowed_by_global: true

So unless that never got set on your instance, somehow…


(Wes Osborn) #4

The correct notification address was in the Admin section.

It appears to have started this morning:

But seems fine after resetting and re-entering the notification email information:


(Jeff Atwood) #5

Hmm that’s really odd any ideas @falco?


(Wes Osborn) #6

Here is what the action log showed:

So it appears that according to the settings it had the right address, but according to Mandril it was using the “default” address.


(Rafael dos Santos Silva) #7

There isn’t any other entry if you filter by change site setting and notification_email ?


(Wes Osborn) #8

Here is everything we have: