"Suggested Topics" displayed as "[en.undefined]" when Google AdSense plugin enabled


#1

Hi, this is a new bug that appeared in the Discourse upgrade I did yesterday. I just updated again now, and the problem continues. (Discourse 1.2.0.beta4 “4dd7610”)


[en.undefined] appearing in place of Sign Up and Log in strings
Google AdSense plugin
#2

My Discourse is up to date also, but ‘Suggested Topics’ appears properly.

Maybe did you customize client.en.yml ?


#3

Hi, thanks for the reply. No, not to my knowledge. It was working before, and I haven’t touched any of the config files since setting it up.


(Jeff Atwood) #4

Looks like a failed upgrade to me, then, I suggest rebuilding via command line

./launcher rebuild app

#5

Hmm, tried that too. Still no change. Any other information that would help in diagnosing?

EDIT: A search for “en.undefined” only returns this:


However, I don’t use that plugin.


#6

Hmm, well, since reporting this I’ve done a few more upgrades and rebuilds, but the error still remains. Anything else I can do to fix this or trace the source of the problem? Thanks!


(Khoa Nguyen) #7

I think that’s google adsense problem. I have this problem before. By the way, gg adsense broke the nice spinner on homepage


Google AdSense plugin
(Jeff Atwood) #8

Do you have any non default plugins installed?


#9

Ah yes, I do have the Adsense plugin running. I disabled it and rebuilt, and this bug goes away. Re-enabling the Adsense plugin makes the bug come back.

Here’s my bug reports:


https://github.com/discoursehosting/discourse-adsense/issues/12

Thanks for the help in troubleshooting this.


#10

https://github.com/discoursehosting/discourse-adsense/issues/13


(Wassame) #11

Hello, I also installed the adsense plugin and have the same problem, but a few more also:

(Latest discourse version installed: 1.3.0.beta1)

  1. [en.undefined] appearing at the bottom,
  2. I notice that I cannot change the topics category, the edit button does not appear either
  3. The favorite button next to the topics title does nothing

I will re-install the app without the adsense plugin to see if it helps!

Edit: Removing the adsense plugin fixed all issues


(Khoa Nguyen) #12

It was fixed