System won't email me (admin)

(Gezim Hoxha) #1

When I first installed Discourse, I had it email me every update and post, etc (small forum). Then I enabled desktop notifications and emails were becoming annoying.

I disabled emails through, I believe, clicking “don’t email me” or something in the email themselves.

Now, for the life of me, I can’t figure out how to get it to send me emails again.

Ideas? (And please do suggest basic things as I’m not too familiar with Discourse).

(Jay Pfaffman) #2

Perhaps you mean the 'disable emails" site setting.

(Gezim Hoxha) #3

Thanks for the response, @pfaffman
So I’m talking about my personal user emails when people reply to a thread or something.

I think I’ve disabled them using this link but for my own forum installation:

How would I re-enable emails if I unsubscribe like this?

(Joshua Rosenfeld) #4

Check your user preferences, specifically the email tab.

(Gezim Hoxha) #5

@jomaxro, here’s how that screen looks like:

I’m not getting any emails from discourse in my account.

Any other suggestion?

(Jay Pfaffman) #6

That’s odd. Does mail work at all?

What do the mail logs say? Have you checked your spam folder?

(Gezim Hoxha) #7

@pfaffman, I sent myself a test email and it showed up fine in my inbox. Checked spam as well and nothing there.

As for the logs, there are sent emails and it seems fine. What happens if I click “unsubscribe” from an email sent by Discourse as I showed in the screenshot here?

(Joshua Rosenfeld) #8

Do you have any categories/topics muted? Check /my/preferences/categories to see if there are any muted categories. You can check for muted topics by clicking “show muted topics” just below the muted categories field.

(Dje4321) #9

Have you tried changing to email setting and changing the setting back? Sounds like it might be showing one thing and doing another

(Gezim Hoxha) #10


I get “There are no latest topics. That’s sad.” URI:

(Gezim Hoxha) #11

Anything in particular I should change?

(Dje4321) #12

Meant more like just changing it to never and back to always and disabling and re enabling all of the email settings

(Gezim Hoxha) #13

@dje4321 tried it but no luck.