Tag sorting for non English locales when creating a topic


(Pad Pors) #1

for Persian locale, and I assume other non English locales, tag sorting doesn’t work when creating topics, i.e. as a user when I start writing the tag for my topic, I see a list of 30-40 tags! and if I continue to write the tag name, no filtering happens in the list.

is this fixable via admin panel?

p.s.: This is a duplicate topic, but I couldn’t find other topic I’ve already read about this before! :frowning:


(Daniela) #2

Have you set max tags per topic?

In my case I see only a list of 5 tags , and they are filtered when I continue to write


(Pad Pors) #3

yes, the max tag per topic is by default 5.

here is what happens:

as you see, I have started writing the tag, in the tag place. and though three characters are written no filtering had happened. while if I do this with English tags, things are alright as you can see:


(Daniela) #4

Mine work exactly as your 2nd screen.

I think it’s somenthing related to your specific installation. If I analyze your site through the browser developer console I see a lot of errors:


(Pad Pors) #5

errors are for a sidebar widget,

and this no-sorting was here even before the installation of the sidebar plugin.

I’ve already seen similar topic in meta:

and that time I thought the behavior is for all non-English languages!

which language is your instance?


(Daniela) #6

My instance is in italian and it works. Probably this bug is for non-latin languages?


(Pad Pors) #7

or perhaps non Latin scripts.

Is this a #bug or can it be fixed using the encoding setting in the admin panel or similar options?

any opinion about this?


(Pad Pors) #8

trying to bring this to top, as it is annoying for non English communities and it doesn’t seem to be a big deal: the function is already there, and it only need to be tuned for new scripts.

thanks for the guides in advance :slight_smile: