Test e-mail "sends" but only I (the creator of the forum) can receive it

Hey all! I got my company’s discourse forum up and running a few weeks back, and everything seemed fine until recently. Now, when someone tries to sign up using the standard form (not using a different service aka google, twitter, etc), they are unable to receive a verification e-mail. What’s strange is that it was working during the first week or so after I created it, but now suddenly seems to have stopped!

I ran through all of the troubleshooting suggestions in the e-mail troubleshooting post but can’t seem to pin down what’s happening. :anguished:

  • I’m using Mailgun for my e-mail service. My domain is verified and all of my DNS records are showing as being set up correctly.
  • There are no strange log messages in the server files or in the admin settings ‘logs’ panel.
  • My connection is not being blocked by Telnet.
  • All my information is correct in terms of address/port/username/authentication/etc.

Again, the weird thing is that it was working up until ~a week ago, give or take a few days. Now I am able to receive a test e-mail from the forum, but no one else is.

Is there maybe a setting or something I could have accidentally turned off somewhere? This bug is really confusing for me, because Mailgun is obviously working, or else I would not be able to receive e-mails… it’s just that no one else can receive them. :disappointed:

Any help would be appreciated! I’m pulling my hair out over this.

Thanks! :blush:

Have you checked your Mailgun logs? You now just provide a credit card number to not be a “free” account in order to send mail.


Aha! That was the problem. I didn’t know you had to add a card. Thanks for the help! :blush:

You can mark my post as “solved.”

Also, I edited the troubleshooting email topic to include this information. The notice in the Mailgun logs is not especially helpful.