The requested URL /u/activate-account/ was not found on this server


(Alexander Øster) #1

Hi all

I am trying to set up my discourse on my own domain using digitalocean, and I have been following a youtube tutorial by PaulNicholson.

Anyhow I recieved a mail from Discourse with the title “Confirm your new account”, and when I click the link, http://defo.dk/u/activate-account/96c903b5872204528371f29bdde67e31, it says The requested URL /u/activate-account/96c903b5872204528371f29bdde67e31 was not found on this server.

Was it something wrong I entered on the terminal?

Thanks in advance


(Régis Hanol) #2

I’d recommend you follow the official guide rather than some random (and probably already outdated) video on youtube.

https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md


(Alexander Øster) #3

I am following that now, but i got stuck at where i have to put ./discourse-setup in to the terminal.
I have already paid for 2 droplets today, so hope you can help. I have attached a screenshot of the terminal

What to do now?

https://imgur.com/a/CTtX6


(Régis Hanol) #4

Why are you doing this?

cd /var/discourse./discourse-setup

It should be

cd /var/discourse
./discourse-setup

(Alexander Øster) #5

I came through that now, and the installation seemed to work. I created a username and password on the droplets ip, but the link that i got send in mail still says the same:

The requested URL /u/activate-account/ was not found on this server

And I recieve the mail each time, so the smtp must be correct.

Do you know how to fix?


(Jay Pfaffman) #6

One guess is that Your have multiple ip addresses for your domain name and that one of them points to another server. No there’s just one address. Did you access discourse using this url to create your account?

Right. Discourse is not running on that server

You can delete the droplets that you’re not using. They are billed by the minute, so you’re not out a bunch of money.


(Alexander Øster) #7

It is a brand new domain, never used before, so only one adress. Yes, found out about the droplets, and have created and deleted 17 but still no luck.

Anyone who may know how to solve my problem?

Does I have to make any FTP settings or anything, before making the droplet and using the terminal/ssh?


(Régis Hanol) #8

Well, did you change the DNS of defo.dk to point at the IP address of your droplet?

Alternatively, have you tried replacing defo.dk with the IP address of your droplet?


(Alexander Øster) #9

Thanks! That did it! I had not changed my DNS to point to the IP address. Thanks!


(Alexander Øster) #10

Which DNS record should I use? A, AAA, CNAME, etc?


(Jay Pfaffman) #11

You want the A record to point to your Digital Ocean droplet.

Make sure that you edit the record and not add a second A record.