in locale is ignored,   works


(Gerhard Schlager) #1

I tried using the character entity   (Thin Space) and   (Narrow no-break space) within a locale file (client.yml). However, it looks like those are converted into a simple whitespace character. The rendered HTML doesn’t contain the entity anymore.

When I’m using the   entity it works as expected and the HTML in the browser still contains the No-break space. Would it be possible to allow other entities as well?


(Sam Saffron) #2

This really depends on the string, and where it is rendered. What is the specific example?


(Gerhard Schlager) #3

One example would be js.dates.tiny.about_x_hours. I tried setting it to %{count} h, %{count} h and %{count} h. Only the last one worked. In all other cases the entity got converted to a space.


(Jeff Atwood) #4

Closing this. As a general rule translations should not have HTML entities.


How to use HTML entities in translations in Transifex?
(Jeff Atwood) #5