# "Title is invalid; try to be a little more descriptive" when the title has really long words in CamelCase

**URL:** https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604
**Category:** Support
**Created:** [21 Luglio 2016, 2:50pm UTC](https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604 "2016-07-21T14:50:10Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![idgserpro](https://avatars.discourse-cdn.com/v4/letter/i/4491bb/32.png) [@idgserpro](https://meta.discourse.org/u/idgserpro)
#### Post date: [21 Luglio 2016, 2:50pm UTC](https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604/1 "2016-07-21T14:50:10Z")

</div>

Add a topic with this title:

> Is “AbortVersioningOfLargeFilesAndImages” and “SkipVersioningOfLargeFilesAndImages” from Products.CMFEditions still needed for Dexterity’s “File” blobs? Is anyone here using them? We’re having problems for \>26mb files.

I’ve tested in [https://try.discourse.org/](https://try.discourse.org/) where I could reproduce the error.

---

<div class="post-metadata">

### Author: ![cpradio](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cpradio/32/4970_2.png) [@cpradio](https://meta.discourse.org/u/cpradio)
#### Post date: [21 Luglio 2016, 3:02pm UTC](https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604/2 "2016-07-21T15:02:55Z")

</div>

See

> [@Are very long words not allowed in topic titles?](https://meta.discourse.org/t/are-very-long-words-not-allowed-in-topic-titles/29683):
>
> We had a user get an email-in topic rejected with the topic: Adding DropMillisecondsHibernateInterceptor for MySQL 5.6+ compatibility With the error message: Title is invalid; try to be a little more descriptive. However, when he changed the title to: Adding an interceptor to drop milliseconds for compatibility with MySQL 5.6 and above The topic was accepted & processed. Does + really cause an email to be rejected? Must it be? If it must, can we at least get a more accurate error mess…

Sounds like you need to tweak this setting: `title_max_word_length`

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [14 Febbraio 2019, 5:11pm UTC](https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604/3 "2019-02-14T17:11:05Z")

</div>



---

<div class="post-metadata">

### Author: ![zogstrip](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/zogstrip/32/512781_2.png) [@zogstrip](https://meta.discourse.org/u/zogstrip)
#### Post date: [15 Febbraio 2019, 5:52pm UTC](https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604/4 "2019-02-15T17:52:58Z")

</div>


