# "Title is invalid; try to be a little more descriptive" when the title has really long words in CamelCase

**URL:** https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604
**Category:** Support
**Created:** [21 يوليو 2016، 2:50م UTC](https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604 "2016-07-21T14:50:10Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![cpradio](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cpradio/32/4970_2.png) [@cpradio](https://meta.discourse.org/u/cpradio)
#### Post date: [21 يوليو 2016، 3:02م UTC](https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604/2 "2016-07-21T15:02:55Z")

</div>

See

> [@Are very long words not allowed in topic titles?](https://meta.discourse.org/t/are-very-long-words-not-allowed-in-topic-titles/29683):
>
> We had a user get an email-in topic rejected with the topic: Adding DropMillisecondsHibernateInterceptor for MySQL 5.6+ compatibility With the error message: Title is invalid; try to be a little more descriptive. However, when he changed the title to: Adding an interceptor to drop milliseconds for compatibility with MySQL 5.6 and above The topic was accepted & processed. Does + really cause an email to be rejected? Must it be? If it must, can we at least get a more accurate error mess…

Sounds like you need to tweak this setting: `title_max_word_length`

---

_[View the full topic](https://meta.discourse.org/t/title-is-invalid-try-to-be-a-little-more-descriptive-when-the-title-has-really-long-words-in-camelcase/47604)._
