Tombstone folder missing?


(Sander Datema) #1

Not sure if this is a bug, but for every (multisite) Discourse instance I see this in the log:

find: '/var/www/discourse/public/tombstone/default': No such file or directory

(Sam Saffron) #2

Whats the backtrace? (you should see it in /logs)


(Sander Datema) #3

I just updated to the latest version that has the logs. I’ll have to wait til the Tombstone error shows up again.


(Jeff Atwood) #4

I believe Sam fixed this when he moved avatars outside the upload pipeline.


(Sam Saffron) #5

nahh tombstone is different, its where (I think) uploads go to die … right @zogstrip ?


(Régis Hanol) #6

yeah, the tombstone is used as a grace period by the remove orphelin uploads job.


(Jonathan Feist) #7

I just got this error pop up in my sidekiq process find: ‘/home/user/www/discourse/public/tombstone/default’: No such file or directory not sure if worth checking out or not. Local install just running the server with thin (and redis-server).


(Sander Datema) #8

That’s the exact same log message I quoted at the beginning of this topic. You can see the replies above.


(Jonathan Feist) #9

With respect, why do you think I’m posting? I’m purposefully bringing attention to it in case it is something the dev team want to take another look at. In the mean time I have simply created a public/tombstone folder. I don’t know if it was obvious or not but I noticed the error pop up in my sidekiq process. And yes, you can see the replies above too.


(Jeff Atwood) #10

At any rate, as covered earlier, you can consider this a warning that can be safely ignored.


(Sander Datema) #11

I wasn’t trying to offend you in any way. But just like Jeff notes: it was something we can ignore.


(Jonathan Feist) #12

Jeff implied that the problem appeared to have been resolved. I posted on the basis that, if I am getting the same error/warning after such an announcement, it might be of minor interest for them to know that the same error/warning is still being output.

As he has now made clear, which it wasn’t prior to my post. This thread may now be considered unambiguous as to whether or not the problem reported can officially be ignored.


(Jason May) #13

This issue still exists. Just a warning, doesn’t seem to affect functionality in any way. I’m see this in my development environment.