Topic filters persist when moving to a different page


(David Taylor) #1

Bit of a weird one. Steps to repro:

  1. Go to a category page, say #bug
  2. Append ?status=closed in your address bar, press enter (or use a link for solved/unsolved/assigned topics)
  3. Observe only closed topics are shown :white_check_mark:
  4. Click on logo to return to “latest”
  5. Be confused that only closed topics are shown in latest :x:
  6. Click the logo again in confusion
  7. Observe that it’s now back to normal :tada:
  8. Visit another page, e.g. view a topic
  9. Click the logo again
  10. Aaaah it’s back to only showing closed topics in latest! :x:

Only way to fix it seems to be to refresh the page

EDIT
Adding a video to this post (Nov 20 2017)
Video added by @nixie


Discourse assign
Reply reminder - Remind users to reply to new users topics with zero replies
Navbar-Link bug
Posts from a particular category missing from homepage - just for the admin user
#2

I think its the same bug I listed here:

I’m seeing this after I installed the code supplied by Falco on that thread.
If anyone would like to know more on this - please contact me - I’m ready to help - in order to fix this bug.


(David Taylor) #3

To bring everything in to one topic, it is also the cause of this issue with the assigned plugin:


(David Taylor) #4

Just to clarify (posting here since the other topic got closed), this bug doesn’t require manually typing a URL - that’s just the simplest repro I came up with. I’ll update the OP to make that clear(Can’t update OP cos the editing window has expired).

It also applies when using links in the UI that apply filters using query parameters. Examples include solved/unsolved buttons for the discourse-solved plugin, or assigned buttons for the assignment plugin.


(Joshua Rosenfeld) #5

Made the OP wiki, feel free to edit.


#6

I’m still eagerly waiting for this to be fixed. :frowning:


(Joshua Rosenfeld) #7

Nixie, as it has been stated previously, this is not a high priority bug. It does not prevent usage of Discourse, and can be easily resolved by manually adjusting the URL. It will be fixed, but I would not expect it to happen soon.


#8

Just doing a silent follow-up on this.

Fixing this bug will let me place links in the header. I’m using the “solved” plugin. And I’ve tried to place a link to “unsolved” topics in the header. Placing a link to the “unsolved” topics in header, is going to “decrease the ETA in solving unsolved queries” in my site. I couldn’t do this yet due to this bug.

Here is a video demonstrating the bug