Topic List Previews


(Tobias Eigen) #366

this is pretty awesome - thanks!

can you consider also fixing the new category/topic 50/50 view on desktop to display featured images instead of user avatar? Totally missing your featured images now that we’re using the new combined category page on our home page.


(Angus McLeod) #367

hm, interesting. Not sure why this would be happening. Is it a significant issue? If so I’ll take a look at more closely next week.


(Angus McLeod) #368

Sure, I’ll take a look at this next week.


(Pad Pors) #369

thanks Angus, that’ll be fine.

just a simple issue: I wanted to keep last contributor’s name and avatar, but i couldn’t hide “,” and “&” between user names, as they’d no class id. is there any clue for this?

btw, the mobile version is great :smiley: thanks.


(ginger man) #370

Thanks for merging the mobile code. Great work.

Pointing to CDN is important for us as it saves the s3 bandwidth costs and for the performance. So it is a significant issue.

Although I am not sure if it is a problem in the plugin or the core piece. As mentioned earlier, it works fine for the original image but only the optimised images are pointing to s3.


(Pad Pors) #371

another minor thing with the social UI:

the bookmark icon in front of posts doesn’t have a fixed position, as you can note in the middle post:


(Angus McLeod) #372

Have you changed the CSS structure of the post at all? Testing rtl view now on my local and it seems to be working fine. The bookmark icon should be in the bottom right with the like icon. Post your CSS changes here.

I’ve added span element to the topic poster names punctuation so you can manipulate it via .topic-poster-names span


(Pad Pors) #373

Thanks Angus,

Yes I have changed the css, I will post it here tomorrow perhaps, as I don’t have access to the local host currently. but if i’m not wrong, I only used a

float: left;

to bring it to the left. Also the shift only happened to the short-excerpt topic, i.e. a topic with excerpt shorter than 100 characters. others were fine. anyway, let me share the UI later to be sure nothing else is wrong.

edit:
.topic-actions {float: left;}

and if the topic-length is short then this causes the bookmark to be in the middle.

i added a width-condition there to fix this in my case:

#list-area.social-media .topic-details {width: 600px;}


(ginger man) #374

@zogstrip I could see all image uploads to S3 are rewritten with CDN url. While this is working for Original image, optimized images are still pointing to S3. I can see this behaviour with the latest commit both for public and private category along with this plugin. I remember the problem being fixed earlier. The below code might be the relevant portion.

This plugin uses the optimized images in the topic lists predominantly.


(Pad Pors) #375

another slight issue Angus, with the social UI the width of all the images have to be larger-equal to 600px. otherwise in the homepage they are blur.

is it possible to set only the max-width and not the width for thumbnails?


(Pad Pors) #376

Hi Angus,

  1. I just note that the topic list is shown blank in chrome. I checked it in 3-4 different laptops and mobile phones.
    may it be due to the social UI?

  2. sometimes when i open our page, all the image thumbnails are hidden! and I need to press F5 and refresh the page so that i see excerpts with thumbnails.

p.s.: i don’t get any error which shows me the problem.


#377

The mobile view works great, and so does the social media layout.

I propose a small addition to the social media layout: allowing it to be enabled for discovery.latest only. I made a little PR for this:

I hope it makes the cut!


#378

@angus one more PR for your perusal that only fixes a small issue with thumbnails on mobile:


(Angus McLeod) #379

@pmusaraj Thanks! Sorry for my slow reply. It’s been a busy week.

I’ve just merged the thumbnail mobile image PR.

Will review the other PR when you’re done updating it.


(Chris Beach) #380

UPDATED: think this relates to the Topic List Previews plugin.

I thought the topic ages had perhaps been intentionally removed in 1.7.0-beta4. Then I saw this while scrolling, which suggests it’s actually a rendering bug (see topic at bottom of list):

UPDATED: have just upgraded the Topic List Previews plugin and the ages now render differently (still broken, but broken in a new way! - no categories showing, and topic ages being superimposed on reply count)

Note to @angus - this bug occurs when topic_list_category_badge_move is set to false. When set to true, categories appear and the display of age/count is correct.


Disable plugin without downtime?
(Angus McLeod) #381

@ChrisBeach Thanks for reporting this. As you say, this affected mobile web if topic_list_category_badge was turned off (and topic_list_mobile_previews was turned off). Fixed.


(Anton) #382

Can social media view be activated per category?


(Pad Pors) #383

just an update about not showing the topic list in chrome:

  1. in desktop chrome, it’s the effect of ad_block, and when I deactivate this chrome add-ons lists are shown.

  2. in mobile chrome, our forum is shown empty.

any one who can help me on this?


#384

My site works fine on Chrome in iOS. It is using the social media display, current version of plugin and discourse.

Do you have a link for your site?


(Pad Pors) #385

https://padpors.com + thanks.