Topic List Previews


(Chris Beach) #406

I’m seeing this too. The “last edit” bar doesn’t seem to work properly. I have the TLP plugin installed


(Angus McLeod) #407

Thanks for all this feedback guys. I’ve been busy this week, but I’ll get to this on the weekend.

cc @jpkh @taylorchu @Pad_Pors @pmusaraj @ChrisBeach


(Anton) #408

Hi @angus,

Any news about the feature re your plugin should only affect categories where it is applied and not change the layout and columns of any other screens?

I’m willing to use your plugin for a “goats herdbook”, where one topic is an entry for one goat. However, I cannot use the plugin unless it stays away from any other categories.

Last time I tried the plugin, it affected output of the categories to which I didn’t apply it.


(王硕) #409

Hi author:

It does not work in development environment.  Thumbnail image can be shown.

Cloud you help fix that?


(Angus McLeod) #410

Hey, could you check 3 settings for me:

  1. That you have thumbnails turned on

  2. That you have social media setting turned on.

  3. That you have a width and height set for thumbnail images. I suggest 600px width for the social media setting.

If you have all of those set, please also check your console for errors like these. This plugin includes a front-end tester for each thumbnail image. If for some reason the image is inaccessible an error will show up in the console.


(Angus McLeod) #411

@jpkh Hey, I’m not seeing this behavior myself - see screenshot below.

The property in the plugin that determines whether the thumbnail will be shown is showThumbnail - see here. That property is determined by the global and category-specific settings - see here.

Here are some reasons why you might be seeing a delay in the thumbnail showing up.

  1. There is some processing required to generate the thumbnail after a topic and its first post are created. This may take longer than the time between when you post the topic and first switch back to the topic list.

  2. If you are using TLP on your local, you have to have sidekiq running for it to work, as it relies on the Cooked Post Processor to create the thumbnails. @11147 This applies to your issue; please confirm you have sidekiq running on your local.


(Angus McLeod) #412

Could you explain a bit more what you mean here? I’m seeing this.


(Angus McLeod) #413

Yes, the category-specific settings only affect the categories they are applied to now.


(Angus McLeod) #414

@pmusaraj I’m not entirely sure what you mean - I think you may be talking about something slightly different from what @taylorchu was suggesting - but happy to review any PR you think would be an improvement.

@taylorchu you mean you want to manually set the thumbnail image right? That feature is on the tbd list. Currently you can set a ‘default’ thumbnail image by adding an image link in the topic list default thumbnail setting.


(taylorchu) #415

No, I mean a checkbox that allows preview image url to directly point to image url in the content (instead of downloading the content image, storing a local copy, and then resizing it as preview image.) The reason behind this is that for server that has no persistent storage, or limited disk space, downloading local copies is infeasible.


(Chris Beach) #416

It seems to affect the mobile view not desktop. A blank line instead of the red line:


(Angus McLeod) #417

I’ve added this setting: topic list hotlink thumbnails. Note that, as I think you know, this will use the full-sized images for each thumbnail.


(Angus McLeod) #418

@ChrisBeach The problem arises when the topic list category badge setting is on. That setting uses the property hideCategory in the topic-list component. There is an observer in the topic-list component that runs a re-render when hideCategory is set. This causes _cleanUpLastVisitedTopic to run, even if there is no category selected, which in turn sets isLastVisited to false and prevTopic to null.

I could try to work around this, however, on preliminary inspection, it seems as though the core Discourse logic may have an issue here. For instance, the topic-list-item-separator also does not display on Meta correctly if you go from the latest Discovery feed to a category and then back to the latest feed again. See: http://quick.as/QWZoinXdb. This is probably connected with the clearing going on in _cleanUpLastVisitedTopic. I don’t have the time tonight to debug this further. I’ll have a look next week.

cc @Falco

ref: Show "updated topics above this line" in the topic list?


(Rafael dos Santos Silva) #419

Current red line has a bug indeed, this have been fixed in this PR.

I misunderstood Ember.js destroy callback, my bad.


(Anton) #420

Can we also make a default thumbnail per category which would override the setting? :blush:


(Pad Pors) #421

p.s.: I meant in the social UI, this may help:


(David) #422

Is this request still being worked for desktop and mobile? I could not find the ability to do it in the latest update.


(Angus McLeod) #423

Already added :slight_smile:


(Angus McLeod) #424

@Pad_Pors Fixed :slight_smile:


(Angus McLeod) #425

This isn’t being worked on yet. However it’s inline with recent work on TLP by @pmusaraj.

@pmusaraj reckon you could take a shot at taking the ‘only latest’ setting for social on the next step?

I’m trying to find some time to work on full page chat