Topic List Previews


#770

Angus’ sandbox:
https://discourse.angusmcleod.com.au/c/tlp


(Donald Swofford) #771

Is there a way to disable topic excerpts for a specific category? I have an FAQ section of my website and it seems like since there isnt an easy anchor link plugin etc that maybe I should remove the excerpts so they can see more Questions on one screen


(Angus McLeod) #772

Yup, that is possible. What topic list settings are currently enabled?


(Donald Swofford) #773

I have the following checked:

topic list set category defaults
topic list previews enabled

And for

topic list excerpt

I have every list in it.


#774

The latest iteration seemed to have broken the listing of topics with tags. Clicking a tag or the list of tags yields a blank page:

Also have Custom Layout, Custom HTML, Events, Quick Messages installed.


(Angus McLeod) #775

@Donald_Swofford @ckshen I am currently travelling. I will look at both issues in more detail next week.


(Hakan) #776

Hi I am a new user, I made settings for this plugin, but I need to change the css. for example I have to do height:auto and object-fit: fill;

with which command can I fix these settings? I could not make the theme from css


(Angus McLeod) #777

@ckshen It’s a layouts plugin issue. It’s fixed. Apologies for the regression.

e.g. Angus' Sandbox

@Donald_Swofford Unfortunately, you currently have to turn off topic list set category defaults and set category-specific Topic List Previews settings for each category if you want to disable excerpts in one category. There’s currently no category-specific ‘exclusion’ settings for the site-wide settings.

@nothing If you need to apply custom CSS, you can add it to the default theme in Site Customisations.


(Hakan) #778

(Hakan) #779

I do not want favicon in the eyes. There is no problem on YouTube but when I add content with a URL on a WordPress site, the site is displayed as a favicon image

Ekran%20Al%C4%B1nt%C4%B1s%C4%B1

I want to visualize the thumbnail of the article inside the article against the thumb


#780

Thank you for the fix! No need for apologies- you are doing it for all of us on your own time, i.e. a favor. We should thank you that there is a plugin at all.


(Angus McLeod) #781

I’ll take a look at the favicon issue tomorrow. I’m not entirely clear on the error message you reported here. Are you still seeing this?


(Hakan) #782

yes im seeing bro.


(Angus McLeod) #783

This issue occurs if you have both

  • Featured images enabled (either on the site or category level); and

  • You’ve set topic list featured images tag to a tag that doesn’t exist.

Either:

  1. Disable featured images (Featured images are images above the topic list, not to be confused with topic list thumbnails, which is probably what you want); or

  2. Use a tag for featured images that exists.


(Hakan) #784

I live this problem from the pictures on my own site.

When I add the subject from the URL, for example, from a blog site, it becomes the thumbnail of the favicon of that blog site. I want the image in the subject to be thumb, not the favicon


(Hakan) #785

You said you’d take care of the favicon tomorrow, but did not you? Favicon does not look, but it does not appear in the subject


(Angus McLeod) #786

From what I understand, the issue is that you’re seeing favicons appear as previewed images (right?).

There is actually already logic to exclude favicons in the plugin, and I can’t reproduce the issue on my sandbox or locally. See e.g.

https://discourse.angusmcleod.com.au/t/this-is-another-post-without-an-image/219

And the associated topic list:

https://discourse.angusmcleod.com.au/c/tlp

Can you point me to a live example of the issue you’re seeing? Thanks.


(Hakan) #787

url posting does not bring the picture in the subject of other.

Image example first post normal post. 2nd post url post


(Angus McLeod) #788

There are two issues here:

  1. Incorrectly using a favicon as a preview image. I cannot reproduce this issue. I tracked down the link from your screenshot, and when I use it, the no preview thumbnail is created, which is the expected behaviour.

    See further: Topic List Previews - Angus' Sandbox

    Are you sure you’re using the latest version of this plugin. What commit shows for this plugin at /admin/docker?

  2. Using a preview from a onebox as a preview image. This has never been supported, but I am adding it now.


(Bart) #789

Hey Angus,

I was digging around in the production logs and noticed that the featured images row does an additional GET request for each pageview. I’m about to deploy the plugin on a high traffic forum and I’m a little worried about performance impact as this would effectively double the load on my server - is there a more effective way to do this, and roll it into the original page request?

Started GET “/tags/featured?featured_images=true&tags_created_at=true&_=1522479449443” for xxx at 2018-03-31 06:57:38 +0000