Topic List Previews


(Daniel Nevoigt) #830

Thanks a lot @angus, the subcategories and other categories are looking like they should now. On Forum startpage I still have that problem. But I fix it with that CSS:

.navigation-categories .featured-topics-discovery {
    display: none;
}

(Bart) #832

Small request from my community: you can’t right-click on the featured images row to open a post in a new tab (or CMD-click). Could you add that?


(Angus McLeod) #833

Sure, I’ll add it a bit later in the week.


(Bart) #834

Fantastic, thank you!

By the way, we went live this weekend with your plugin and it looks fantastic (see link below). The site is receiving very high traffic and I was wondering if you are using any caching in your code? Are you fetching the latest tag results for every pageview? Caching the results even for a few minutes might help offload our poor server a little :wink:


(Angus McLeod) #835

The short answer is yes, this plugin does a bunch of ‘caching’ :slight_smile:

I get where you’re coming from. I don’t have a huge amount of time right now, but I’ll see what I can do when I have a spare moment.

If it’s a big issue you may want to consider hiring someone to look at it in-depth. I don’t do paid gigs, but I’m happy to accomodate outside changes.


(Bart) #836

Good, that’s all I needed to know for now. I don’t have any indications that it’s your plugin that’s causing the server load, just trying to rule out any possible causes.


(Angus McLeod) #837

@bartv You can now right-click (or cmd click) to open in a new tab.

@Daniel_Nevoigt I still can’t repro your issue. Are you sure you don’t have the Site Setting
topic list featured images turned on? This setting is poorly named. It should be “topic list featured images non-category” or something, as it only turns on featured images for non-category routes. I’ve updated the label.


#838

Hey Agnus I just updated and my latest section is all messed up. Is there a css fix for this? Looks like the opacity and everything is all messed up. Like a big gray block over a white background.


(Angus McLeod) #839

Please list the settings you’re using, what you’re seeing in the web console and link me to your site if possible.


(Angus McLeod) #840

This has been resolved via pm.


#841

Does the ‘topic list default thumbnail fallback’ stop working for anybody here besides me after updating to latest beta +10 plus latest plugin?


#842

@Angus I am pretty sure the default thumbnail stopped working, either the universal setting or the by-category setting. The default thumbnail just won’t display no matter how I fiddle with the setting. Just FYI.

I can’t tell for sure whether you enabled the default thumbnail in your sandbox but I think you didn’t.


(Angus McLeod) #843

It should work now :sunny:

Live with examples here: Topic List Previews - Angus' Sandbox


#844

Cheers, Angus. Looks good in your sandbox. I will update.


(Hakan) #845

Can we upload images to the server in posts added from YouTube and other sites? uploaded images slow down the speed of the site, can we upload these images to the server?


(Bart) #846

What do you mean with this? I’ve found no problems with the performance of Youtube or other media embeds.


(David Kingham) #847

I have some featured image requests:

This was mentioned previously about removing the tag below the featured images as an option, easy enough to remove it via css, but you mentioned it would be added as an option.

A horizontal scrollbar is showing for me as well…

I would love to have a title above the featured images that could be typed in.

Is it possible to move the featured images above the categories?

Here is a mockup of what I would like to achieve:


(Colin Marshall) #848

If your site is public, please provide a link and I can probably figure it out for you.


(Angus McLeod) #849

I’ve added the setting topic list featured images tag show to let you do this.

I’m guessing you’re using IE? This should fix it.

I’ve added a setting that will let you add text above the featured images. It supports markdown, but you’ll need to style it yourself using site customisations.

Add this to your default theme’s </head>

<script type="text/discourse-plugin" version='0.8.13'>
api.modifyClass('component:tlp-featured-topics', {
  moveFeaturedTopics: function() {
    Ember.run.scheduleOnce('afterRender', () => {
      this.$().insertBefore('.category-boxes');
    })
  }.on('didInsertElement')
})
</script>

(David Kingham) #850

Thank you Angus! Such an amazing plugin.

Nope I tested on all browsers, mac and windows. This fixed it though!

Works beautifully

This doesn’t seem to work, but now that I have everything setup I actually like where it’s positioned.

One more question; how would I go about changing the color of the text in the featured details overlay? I tried this with no results:
.featured-details {
color: #feda6a;
}
image