# Aliyun email push not working

**URL:** https://meta.discourse.org/t/topic/396468
**Category:** Support
**Tags:** email
**Created:** [February 19, 2026, 4:58am UTC](https://meta.discourse.org/t/topic/396468 "2026-02-19T04:58:57Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![AkarinLiu](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/akarinliu/32/539577_2.png) [@AkarinLiu](https://meta.discourse.org/u/AkarinLiu)
#### Post date: [February 19, 2026, 4:58am UTC](https://meta.discourse.org/t/topic/396468/1 "2026-02-19T04:58:57Z")

</div>

I am currently configuring the Alibaba Cloud email push service for Discourse, but I keep encountering obstacles, and the email push service cannot be used normally. Can you find the problem?

```plaintext
==================== DOCKER INFO ====================
DOCKER VERSION: Docker version 29.2.1, build a5c7197

DOCKER PROCESSES (docker ps -a)

CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
412d2aebeefc local_discourse/app "/sbin/boot" 4 seconds ago Up 3 seconds 0.0.0.0:80->80/tcp, [::]:80->80/tcp, 0.0.0.0:443->443/tcp, [::]:443->443/tcp app

412d2aebeefc local_discourse/app "/sbin/boot" 4 seconds ago Up 3 seconds 0.0.0.0:80->80/tcp, [::]:80->80/tcp, 0.0.0.0:443->443/tcp, [::]:443->443/tcp app

Discourse container app is running

==================== PLUGINS ====================
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/sydomo/discourse-cloudflare-turnstile.git

WARNING:
You have what appear to be non-official plugins.
If you are having trouble, you should disable them and try rebuilding again.

See https://github.com/discourse/discourse/blob/main/lib/plugin/metadata.rb for the official list.

========================================
Discourse version at communitytest.akarinliu.com: NOT FOUND
Discourse version at localhost: NOT FOUND

==================== MEMORY INFORMATION ====================
RAM (MB): 2069

               total used free shared buff/cache available
Mem: 1973 479 1191 18 492 1493
Swap: 2047 68 1979

==================== DISK SPACE CHECK ====================
---------- OS Disk Space ----------
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 30G 8.8G 20G 32% /

==================== DISK INFORMATION ====================
Disk /dev/sda: 30 GiB, 32212254720 bytes, 62914560 sectors
Disk model: QEMU HARDDISK
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x86a4d272

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 62914526 62912479 30G 83 Linux

==================== END DISK INFORMATION ====================

==================== MAIL TEST ====================
For a robust test, get an address from http://www.mail-tester.com/
Or just send a test message to yourself.
Email address for mail test? ('n' to skip) [akarinliu@outlook.com]:
Sending mail to akarinliu@outlook.com. . .
Testing sending to akarinliu@outlook.com using smtpdm.aliyun.com:465, username:hi@notify.akarinliu.com with plain auth.
==================================== ERROR ====================================
UNKNOWN ERROR!
Net::ReadTimeout: Net::ReadTimeout with #<TCPSocket:(closed)>
=================================== SOLUTION ===================================
This is not a common error. No recommended solution exists!

Please report the exact error message above to https://meta.discourse.org/
(And a solution, if you find one!)
================================================================================
Replacing: SMTP_PASSWORD
Replacing: LETSENCRYPT_ACCOUNT_EMAIL
Replacing: DEVELOPER_EMAILS
Replacing: DISCOURSE_DB_PASSWORD
Replacing: Sending mail to

==================== DONE! ====================
Would you like to serve a publicly available version of this file? (Y/n) n
'Publicly available log not generated.

You can examine the output of this script with
LESS=-Ri less /tmp/discourse-debug.txt

BUT FIRST, make sure that you know the first three commands below!!!

Commands to know when viewing the file with the above command (called 'less'):
q -- quit
/error<ENTER> -- search for the word 'error'
n -- search for the next occurrence
g -- go to the beginning of the file
f -- go forward a page
b -- go back a page
G -- go to the end of the file

```

---

<div class="post-metadata">

### Author: ![itsbhanusharma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itsbhanusharma/32/180717_2.png) [@itsbhanusharma](https://meta.discourse.org/u/itsbhanusharma)
#### Post date: [February 19, 2026, 6:14am UTC](https://meta.discourse.org/t/topic/396468/2 "2026-02-19T06:14:03Z")

</div>

> [@AkarinLiu](#):
>
> ```plaintext
> Testing sending to akarinliu@outlook.com using smtpdm.aliyun.com:465, username:hi@notify.akarinliu.com with plain auth.
> ==================================== ERROR ====================================
> UNKNOWN ERROR!
> Net::ReadTimeout: Net::ReadTimeout with #<TCPSocket:(closed)>
> 
> ```

Are you able to telnet into the smtp server?

`telnet smtpadm.aliyun.com 465`

---

<div class="post-metadata">

### Author: ![AkarinLiu](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/akarinliu/32/539577_2.png) [@AkarinLiu](https://meta.discourse.org/u/AkarinLiu)
#### Post date: [February 20, 2026, 3:50am UTC](https://meta.discourse.org/t/topic/396468/3 "2026-02-20T03:50:58Z")

</div>

Yes, but port 465 cannot be used to send emails.

---

<div class="post-metadata">

### Author: ![itsbhanusharma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itsbhanusharma/32/180717_2.png) [@itsbhanusharma](https://meta.discourse.org/u/itsbhanusharma)
#### Post date: [February 20, 2026, 4:25am UTC](https://meta.discourse.org/t/topic/396468/4 "2026-02-20T04:25:58Z")

</div>

This could be due to something specific to your ESP, there were recent reports from another ESP causing issues, does aliyun support any other ports for sending?

---

<div class="post-metadata">

### Author: ![AkarinLiu](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/akarinliu/32/539577_2.png) [@AkarinLiu](https://meta.discourse.org/u/AkarinLiu)
#### Post date: [February 20, 2026, 4:34am UTC](https://meta.discourse.org/t/topic/396468/5 "2026-02-20T04:34:13Z")

</div>

Supports sending emails on ports 25 and 80; port 465 cannot be used normally.

---

<div class="post-metadata">

### Author: ![itsbhanusharma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itsbhanusharma/32/180717_2.png) [@itsbhanusharma](https://meta.discourse.org/u/itsbhanusharma)
#### Post date: [February 20, 2026, 4:54am UTC](https://meta.discourse.org/t/topic/396468/6 "2026-02-20T04:54:52Z")

</div>

They don’t support 587 or 2525?

---

<div class="post-metadata">

### Author: ![AkarinLiu](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/akarinliu/32/539577_2.png) [@AkarinLiu](https://meta.discourse.org/u/AkarinLiu)
#### Post date: [February 20, 2026, 5:05am UTC](https://meta.discourse.org/t/topic/396468/7 "2026-02-20T05:05:15Z")

</div>

Yes, I submitted feedback to the official channels requesting that the service provider offer port 587 for email push services.

 ![Image](https://global.discourse-cdn.com/meta/original/4X/2/2/f/22fea341f014ea1f2abf553b33ea28543dec46d0.jpeg)

---

<div class="post-metadata">

### Author: ![AkarinLiu](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/akarinliu/32/539577_2.png) [@AkarinLiu](https://meta.discourse.org/u/AkarinLiu)
#### Post date: [March 1, 2026, 3:45am UTC](https://meta.discourse.org/t/topic/396468/8 "2026-03-01T03:45:07Z")

</div>

I switched from Alibaba Cloud Mail Push Service to Brevo because my Outlook was not receiving emails, and the IP was being rejected…
