Topics appear blank in development mode


(Paxmanchris) #1

I got discourse up and running using vagrant. As you can see here:

How ever when I view topics, it just has the loading icon, and never displays (or at least I waited 4mins):

If I try to load the page directly it show up blank:


(Kane York) #2

What’s in the JS console


(Paxmanchris) #3

0/assets/discourse/lib/click_track.js?body=1 net::ERR_BLOCKED_BY_CLIENT
52:277 GET http://127.0.0.1:4000/assets/discourse/lib/page_tracker.js?body=1 net::ERR_BLOCKED_BY_CLIENT
52:433 GET http://127.0.0.1:4000/assets/discourse/views/share-button.js?body=1 net::ERR_BLOCKED_BY_CLIENT
52:700 GET http://127.0.0.1:4000/assets/discourse/initializers/page-tracking.js?body=1 net::ERR_BLOCKED_BY_CLIENT
ember.js?body=1:3936 DEBUG: -------------------------------
ember.js?body=1:3936 DEBUG: Ember : 1.9.0
ember.js?body=1:3936 DEBUG: Handlebars : 2.0.0
ember.js?body=1:3936 DEBUG: jQuery : 2.1.1
ember.js?body=1:3936 DEBUG: -------------------------------
loader.js?body=1:46 Uncaught Error: Could not find module discourse/views/share-button
loader.js?body=1:46 Uncaught Error: Could not find module discourse/views/share-button
ember.js?body=1:3936 DEBUG: For more advanced debugging, install the Ember Inspector from Ember Inspector - Chrome Web Store


(Paxmanchris) #4

After searching ERR_BLOCKED_BY_CLIENT, I found this post, and tried loading the page in Safari. It seams my ublock extension is stopping localhost from displaying the page. After disabling ublock, I can now view the post.


(Kane York) #5

Yep, just disable µBlock on localhost, that’s what I do.

In the future, just check for BLOCKED_BY_CLIENT if a webpage breaks, then you know that you need to add exemption rules.


(Régis Hanol) #6