Trouble configuring DNS

I’m having some trouble configuring the DNS. I followed the 30-minute install instructions including choosing the domain. I also added CNAME to point to my domain. I followed the instructions provided here Configure your domain name for hosted Discourse

The problem is that I still can’t access Discourse using my domain/subdomain. I can only access it using the IP address. Any help will be appreciated.

Did you “do” that part? You can check the state of propagation here:

I don’t think I waited long enough. I am just wondering if I didn’t do it right. I am also confused with this step:

Do you or anyone know what that means?

Thank you

That’s an instruction specific to Discourse instances hosted by us (CDCK, the makers of Discourse). If you’re self-hosting, you won’t get a welcome e-mail, and should instead configure DNS to create an A record pointing to the IP address of the server you installed Discourse on.

So I am creating an A record now. In the point to field, I’d put the IP address of the server. How about the host field? What should I put in there?

It’s probably the domain name you want to point to your server, but you should ask your DNS provider’s support team for clarification, because (a) they’ll know their systems than we do, especially since (b) we don’t know who your DNS provider even is.

1 Like

My domain registrar is Godaddy. I used DigitalOcean for the installation. I will write forums in the host field since my plan is to use Discourse as a subdomain []

Alright so now my subdomain works fine. The installation is completed. Now I’m on the Register Admin Account page. I used my Gmail email address earlier but I didn’t receive any confirmation email. I tried using my domain’s email address that I have (basically an Office 365 Email address), I didn’t receive any email either. I used SparkPost as my email server. Am I missing something?

Have you tried the steps here?

Thank you. I just spent an hour going through each step and trying it. Unfortunately, nothing worked.

Nothing worked is vague. None of the steps in the troubleshooting guide worked? Each step checks a different aspect of email and needs a different fix.

All of the steps in the guide worked, but email still isn’t working for you? You might need to change email provider. Gmail has been problematic, I don’t know if that has improved. I don’t know about Office. Unless you have a provider in the market for mass delivery, you might have issues.

My bad, I meant that I followed each step in the troubleshooting guide but I still haven’t received any email. What email provider that would 100% work with Discourse? Any suggestion?

I’m pretty sure by now I’ve seen reports of problems with all the big names at one time or another, so “100% work” is a bridge too far, IMO. People seem to be able to get e-mail delivery working with most of the big names, though, with a bit of jiggling. Sparkpost and mailgun are the two names that come immediately to mind, so perhaps try them first?

Thank you for your suggestion. The thing is, I am using Sparkpost as my email provider. This is my first time using it so I think I am using it wrong. Am I supposed to link it to my actual email address? Is there a tutorial that explains how to use it as an email provider and how can I use it with Office 365 email?

If you’re having problems with Sparkpost, you’ll be best off talking with their support people. Once the e-mail has gone out of Discourse and into their systems, there’s nothing we can do to help you from there.

1 Like

So I contacted SparkPost and I was able to solve the problem. I am now able to receive the admin confirmation email. The issue was that their GSL blocks messages to certain role based addresses, as described in this article – Global Suppression List - SparkPost

And since I was using postmaster@[mydomain.tld] ( postmaster is a role based address), that’s why the confirmation email was blocked. I was able to solve that issue by using an email address that was not role based.

I just wanted to inform whoever might face a similar issue about the possible solution.

Thank you all.