Trouble enabling automatic backups to S3


(Justin Gordon) #1

Related to this topic:

My backups are failing with this message:

[2014-11-27 18:30:00 +0000] EXCEPTION: Missing required arguments: aws_access_key_id, aws_secret_access_key
[2014-11-27 18:30:00 +0000] /var/www/discourse/vendor/bundle/ruby/2.0.0/gems/fog-core-1.24.0/lib/fog/core/service.rb:237:in `validate_options’

However, I’m 100% sure that I have “s3 access key id” and “s3 secret access key” set on the settings/file tab. I also have “enable 23 uploads” turned to false and no “s3 upload bucket” set. I’m using IAM access keys configured per the instructions. I have the s3 region set to us-west-1, and that should correspond to my my bucket.

How do I troubleshoot this?

I’d like to suggest that the configuration for using S3 for backups, but not images, is a bit confusing, as from the backups tab, you need to know that you set the S3 credentials on the Files tab.


(Khoa Nguyen) #2

Is your IAM access keys can access the backup bucket?
I used to have this error becasue the IAM key can’t access the backup bucket (It only can access the image bucket)


(Justin Gordon) #3
  1. How do I verify that IAM is set correctly?
  2. The error message says the keys are missing. I’m wondering if the issue is that I’m not using S3 for image storage.

Thanks!


(Khoa Nguyen) #4
  1. Use a master key of your amazon console instead of a IAM key (just for testing)
  2. Tried to disabled “setting >> files >> s3 use iam profile”