# 수 시간 후 discourse 업데이트 실패 - POSTGRES 업그레이드 실패

**URL:** https://meta.discourse.org/t/trouble-updating-discourse-after-some-time-upgrade-of-postgres-failed/389116
**Category:** Support
**Created:** [11월 19, 2025, 10:33오후 UTC](https://meta.discourse.org/t/trouble-updating-discourse-after-some-time-upgrade-of-postgres-failed/389116 "2025-11-19T22:33:48Z")
**Posts on this page:** 1
**Showing post:** 1

<div class="post-metadata">

### Author: ![nickharambee1](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/nickharambee1/32/530393_2.png) [@nickharambee1](https://meta.discourse.org/u/nickharambee1)
#### Post date: [11월 19, 2025, 10:33오후 UTC](https://meta.discourse.org/t/trouble-updating-discourse-after-some-time-upgrade-of-postgres-failed/389116/1 "2025-11-19T22:33:48Z")

</div>

오랜만에 Discourse를 업그레이드하려고 오늘 시도해 보았습니다. 브라우저에서 `admin/update` 페이지를 열었는데, 모든 것이 최신 상태라는 메시지가 표시되지만, 현재 표시되는 버전은 v2.4.0.beta2 +17입니다. 최신 버전이 3.6.0.beta2라는 것을 알고 있습니다.

그래서 터미널에서 `./launcher rebuild app` 명령어를 사용하여 업데이트를 시도해 보았으나, UPGRADE OF POSTGRES FAILED(포스트그레SQL 업그레이드 실패)라는 메시지와 함께 실패했습니다. [지원 페이지](https://meta.discourse.org/t/postgresql-13-update/172563)를 읽고 해당 페이지와 포스트그레SQL 업데이트 문제와 관련된 유사한 게시물의 모든 지시를 따랐지만, 문제를 해결하지 못했습니다.

/var/discourse/shared/standalone/log/var-log/postgres의 로그를 확인해 보았는데, 다음과 같은 반복적인 오류 메시지를 발견했습니다:

`2025-11-19 21:42:13.815 GMT [242] LOG: skipping missing configuration file “/shared/postgres_data/postgresql.auto.conf”`  
`2025-11-19 21:42:13.816 UTC [242] FATAL: data directory “/shared/postgres_data” has wrong ownership`  
`2025-11-19 21:42:13.816 UTC [242] HINT: The server must be started by the user that owns the data directory.`

한 가지 이해가 안 되는 점은 `/shared/postgres_data` 디렉터리가 없고, `/shared/standalone/postgres_data` 디렉터리가 있다는 것입니다.

터미널에서 발생한 오류 메시지는 아래에 포함해 두었습니다. 업그레이드가 정상적으로 작동하도록 도와주는 힌트가 있다면 감사하겠습니다.

감사합니다,

Nick

* * *

```plaintext
Success. You can now start the database server using:

    /usr/lib/postgresql/13/bin/pg_ctl -D /shared/postgres_data_new -l logfile start

Ign:1 
 buster-pgdg InRelease

Ign:2 
 buster/updates InRelease

Err:3 
 buster-pgdg Release

  404 Not Found [IP: 151.101.67.52 80]

Err:4 
 buster/updates Release

  404 Not Found [IP: 151.101.2.132 80]

Ign:5 
 buster InRelease

Ign:6 
 buster-updates InRelease

Err:7 
 buster Release

  404 Not Found [IP: 151.101.2.132 80]

Err:8 
 buster-updates Release

  404 Not Found [IP: 151.101.2.132 80]

Get:9 https://deb.nodesource.com/node_15.x buster InRelease [4,584 B]

Reading package lists...

Reading package lists...

Building dependency tree...

Reading state information...

The following additional packages will be installed:

  postgresql-client-10

Suggested packages:

  postgresql-doc-10

The following NEW packages will be installed:

  postgresql-10 postgresql-client-10

0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.

Need to get 6,441 kB of archives.

After this operation, 30.6 MB of additional disk space will be used.

Err:1 
 buster-pgdg/main amd64 postgresql-client-10 amd64 10.17-1.pgdg100+1

  404 Not Found [IP: 151.101.195.52 80]

Err:2 
 buster-pgdg/main amd64 postgresql-10 amd64 10.17-1.pgdg100+1

  404 Not Found [IP: 151.101.195.52 80]

Stopping PostgreSQL 13 database server: main.

check for "/usr/lib/postgresql/10/bin" failed: No such file or directory

Failure, exiting

-------------------------------------------------------------------------------------

UPGRADE OF POSTGRES FAILED

Please visit 
 for support.

You can run ./launcher start app to restart your app in the meanwhile

FAILED

--------------------

Pups::ExecError: /root/upgrade_postgres failed with return #<Process::Status: pid 50 exit 1>

Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'

exec failed with the params "/root/upgrade_postgres"

9f400ba2cca88f79359496e95027cf26c2d5a3672837c5594793cf723585407b

**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.

./discourse-doctor may help diagnose the problem.

```

---

_[View the full topic](https://meta.discourse.org/t/trouble-updating-discourse-after-some-time-upgrade-of-postgres-failed/389116)._
