Trouble with activation links with web port other than 80


(David Krcek) #1

Hey folks,

i need some help with my configuration. i did a standalone installation and use mandrill as smtp server.
Because of port 80 is used by my lighttpd server i decide to use port 8080.
Relevant parts of my config:

    ## this is the all-in-one, standalone Discourse Docker container template
templates:
  - "templates/cron.template.yml"
  - "templates/syslog.template.yml"
  - "templates/postgres.template.yml"
  - "templates/redis.template.yml"
  - "templates/sshd.template.yml"
  - "templates/web.template.yml"

## which TCP/IP ports should this container expose?
expose:
  - "8080:80"   # fwd host port 80   to container port 80 (http)
  ...... 

  DISCOURSE_DEVELOPER_EMAILS: 'admin@xxxx.de'
  ##
  ## The domain name this Discourse instance will respond to
  DISCOURSE_HOSTNAME: 'discourse.switchxxxx.de'
  ##
  ## The mailserver this Discourse instance will use
  DISCOURSE_SMTP_ADDRESS: smtp.mandrillapp.com # (mandatory)
  DISCOURSE_SMTP_PORT: 587                     # (optional)
  DISCOURSE_SMTP_USER_NAME: xxxx  # (optional)
  DISCOURSE_SMTP_PASSWORD: xxxxx #(optional)

After registration user get their emails with an activation link. But instead of

http://discourse.switchxxxxx.de:8080/users/activate-account.... 

the port is missing and the activation looks like:

http://discourse.switchxxxxx.de/users/activate-account..... 

What i did wrong?

Thanks
David


(David Krcek) #2

OMG… Should use search engine in a better way :wink:

Goto admin->settings->developer and change port to 8080 (default is empty).

Please close thread. Thanx


Trouble with activation links with web port other than 80, again
(Régis Hanol) #3