Twitter Sign-up Bug


(Nick Caldwell) #1

Couldn’t find a similar error, so here goes.

Steps:

  1. set up Twitter secret etc etc
  2. test by clicking sign-up button
  3. click “with Twitter”
  4. round-trip to Twitter OAuth
  5. Check Name/Email/Username on return
  6. Submit
  7. Huh?

So, yeah.

Addendum: running latest code on a DigitalOcean box using Sam’s Docker image. Haven’t checked logs yet, but willing to accept hints on which logs to look for.


(Jeff Atwood) #2

Twitter, at last check, is a bit unique in that they do not provide a valid verified email address during sign up. Someone said they support oauth 2.0 now finally so we need to revisit this.

Can you check again when you get a chance @sam?


(Nick Caldwell) #3

I guess there’s also a missing condition to check for when rendering the error message banner? If it’s not a password issue, per se, then it should probably output different wording.


(Sam Saffron) #4

Yeah, twitter still do not provide emails, just double checked. Not much we can do here.

@ABillionSuns how should we communicate this fact to the users clicking on the twitter button ?


(Nick Caldwell) #5

I’m not sure because I’m still not 100% on what has happened - if sign-up is impossible right now, just remove the button entirely, surely?


(Sam Saffron) #6

you can still log in with twitter, its just that you must provide your email


(Nick Caldwell) #7

Hmm. I checked with a different Twitter account, made sure the email address I used matched, and the sign-up still fails as above.

If that weren’t the case, the wording I’d suggest would be:

Add the email address linked with your Twitter account to finish signing up.

(Nick Caldwell) #8

Yeah, tried a few other accounts to verify - it’s outright busted.


(Sam Saffron) #9

Its possible there is a regression here, it is wanting a password and it should not need one.


(Nick Caldwell) #10

Not a dealbreaker by any means; just kicking the tires. I’ll be looking at the Facebook signup flow next.


(Nick Caldwell) #11

OK, not just a Twitter bug - signup by any means seems to be completely busted on 29ba471. I’m 1 commit behind, but I didn’t see anything in the log to suggest it was fixed in the later commit.


(Jeff Atwood) #12

I was able to log in fine just now on try.discourse.com with username/password combo. Let me try Twitter.

edit: yeah, Twitter signup is definitely broken.

edit: gmail signup works fine. So this is specific to the peculiarity of Twitter not allowing anyone to get a valid email address.


(Nick Caldwell) #13

I got a friend to try Facebook signup - that was also broken. Finally, he tried the native signup flow, came to the same end.


(Jeff Atwood) #14

Yep confirmed, with Facebook I also get “password must be 6 characters or longer”. Odd that Google signup still works.

@Neil I think this is your regression?


(Neil Lalonde) #15

No, but I’ll look. :wink:


(Neil Lalonde) #16

I fixed this. The client js had different logic for whether a password is needed for twitter or not. And Facebook was missing something entirely. I think it’s been this way since August!


(Jeff Atwood) #17

Thanks. I guess this means local credentials and Google are extremely dominant for new user signups? Otherwise I would have expected more complaints…


(Nick Caldwell) #18

Confirmed Twitter sign-up works, have asked a friend again to try the Facebook sign-up. Thanks loads, guys!


(Jeff Atwood) #19