Unable Receive Activation Emails


#1

Hi,

I am new here, just install Discourse on DO, but cant receive email.

I was unable receive the activation email, I was keep search related post, change and rebuild app still no working, trying with shared hosting SMTP and mailgun.

Mailgun I have receive domain activate, but seems still unable sent out mail, is that no added credit card will not allow to sent mail?

Currently I got one shared hosting, I have try using the SMTP of the shared hosting, but keep refuse, and the hosting support told me,

“mail is CNAME to example . com.
So if you point example .com A record to other side, you will need change mail.example . com to our own server 43.225.xxx.xxx. Then update MX record to mail.example . com.
Then your SMTP only can work well.”

As checking log, seems was complete, but I no receive any email.

Any wrong on setting?


#2

Have you tried going through this also?


(Jay Pfaffman) #3

What do your mailgun logs show?

Have you tried using port 2525 instead of 587?


#4
  1. Yea, changing mailgun port to 2525 is working. Because I not added CC info, seems much of mail been rejected when checking log, just receive few.

Will any pre-charge if I added my CC, will it auto charge when mail outgoing mail above 10k ? Now in free plan.

  1. About my self mail host, according to DO, for newest account will take 60 day to quality in order to sent mail, avoid spam.

  2. Elasticmail, I have unable added new domain now, according to them, my DO Docker host IP is in blacklisted, now waiting DO reply about this.