Unable to accept invitation to discourse

I am unable to accept invitation as a test user for my discourse forum.

Included is the picture of the screen I am having issues with where clicking on the “Accept Invitation” button does nothing. This occurs on Chrome and Firefox.

1 Like

I have seen this before and the issue was traffic not being forced to HTTPS.

1 Like

Do you know what I can do to fix it? I’m a fair noob at this.

Make sure that all traffic is being forced to HTTPS. :slight_smile:

This may not be your issue but without more details we can’t really help. Are you self hosting?

1 Like

Yes, I am on Digital Ocean.

Please feel free to let me know what details I can send or show here.

Here is my security overview

I am self-hosting
I upgraded Discourse yesterday or the day before
I had to rebuild the package using the console/CLI because the upgrade was disabled on the GUI (I think because of the prior upgrade not finishing completely)
I also upgraded Ubuntu and ensured that security updates are automagically applied.

1 Like

@HAWK – it is discourse.netsuitecommunity.com if that helps? I do not know where to turn for support anymore. Any advice is appreciated.

1 Like

Is the site setting force https turned on? That will force all traffic to use HTTPS.

3 Likes

Hi @justin – apologies on the late reply, went on first vacation in 11 years.

Unfortunately, I never noticed such setting in the wizard. I am actually unable to get the wizard now, but that is another request.
Force https setting - I do not see such a setting in the settings screenshot below where I have searched for https. Is there somewhere else I should be looking? I am using a droplet/docker on digital ocean and I do not believe there is any https settings there either?

If you don’t see the setting, then it’s on.

You might upgrade again and see if the problem persists.

I rebuilt the app. I am upgraded as of today as well. I think it is time to throw in the towel and make an entirely new droplet.

I just had this same issue, but clicking on the button using Inspect Element and changing it from “disabled” to “enabled” fixed the issue. I’m not sure if it has to do with the new invitation system in place. Nobody else was experiencing the same issue as me.

Actually, maybe it would be best if this topic was locked.

1 Like