# Unable To Connect/Connection Refused due to https certificates

**URL:** https://meta.discourse.org/t/unable-to-connect-connection-refused-due-to-https-certificates/51276
**Category:** Self-hosting
**Created:** [October 8, 2016, 11:52pm UTC](https://meta.discourse.org/t/unable-to-connect-connection-refused-due-to-https-certificates/51276 "2016-10-08T23:52:43Z")
**Posts on this page:** 1
**Showing post:** 7

<div class="post-metadata">

### Author: ![lucasbasquerotto](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/lucasbasquerotto/32/133376_2.png) [@lucasbasquerotto](https://meta.discourse.org/u/lucasbasquerotto)
#### Post date: [June 26, 2019, 11:56pm UTC](https://meta.discourse.org/t/unable-to-connect-connection-refused-due-to-https-certificates/51276/7 "2019-06-26T23:56:10Z")

</div>

For anyone that face it in the future, make sure to not exceed the rate limit of LetsEncrypt:

> [@After initial setup of DigitalOcean droplet, get Refused to Connect error](https://meta.discourse.org/t/after-initial-setup-of-digitalocean-droplet-get-refused-to-connect-error/45002/4):
>
> Just to point out something that happened to me. I used a testing server whose setup is entirely done by ansible, and after I use the site, I destroy it (ansible handles the destruction of the droplets, digital ocean spaces and so on, so that I’m not charged when not using). What happened is that LetsEncrypt have rate limits, and my domain exceeded, so I started receiving the error that the page couldn’t be reached and it was a bit hard to track the reason to the rate limit of certificates (fir…

You can see if it was exceeded in the logs:

`./launcher logs app`

---

_[View the full topic](https://meta.discourse.org/t/unable-to-connect-connection-refused-due-to-https-certificates/51276)._
