Unable to Edit a Topic after Posting

(Aisha I) #1

Sorry, this might be a basic question but I’m new to Discourse.

I posted a topic and need to edit it it to add a link. In a previous Meta post, a user was instructed to select the edit pencil icon. However, no edit function appears anywhere on my topic or admin options, as you can see below. Any help would be appreciated!

(Daniela) #2

How do you set up post edit time limit in your site settings?

(Dean Taylor) #3

Looks like the icon font is not loading looking at your admin menu compared to the usual one:

Try refreshing the page and ensuring you haven’t got any browser plugins / network issues which might be preventing elements of the page from loading.
Perhaps check any customisations you have added to the site.

(Daniela) #4

It seems that he use Glyphicons instead of Fontawesome

downloadable font: download failed (font-family: "Glyphicons Halflings" style:normal weight:normal stretch:normal src index:1): status=2147746065 source: https://ebiz.sfn.org/SSO/skins/sfn/fonts/glyphicons-halflings/glyphicons-halflings-regular.woff

(Neil Lalonde) #5

@Aisha_I Looks like the post action buttons are missing or hidden on sfn.org. I’m not sure if it was done on purpose…

(Daniela) #6

The buttons are still there but they are invisible because the icons do not load (you can see the hover background when you go over with the mouse).

(Daniela) #7

This is what I see in the browser console

(Aisha I) #8


Thanks for your responses! I checked the post edit time limit and it’s set to 0 minutes. @neil, is there a way to hide/unhide the post action buttons in settings?

(Daniela) #9

You can decide which buttons users must see, which buttons user can see (when they click on ) and which buttons you don’t want at all (not recommended).

In your site settings search for post menu and post menu hidden items.

BTW now your problem is that no button is visible for your users, you need to understand why your Glyphicons icons do not load properly or at least restore the default Fontawesome icons.

(Aisha I) #10

I see, that makes sense. The site settings were done by my predecessor and I’m trying to navigate around them while I’m learning Discourse. How would I restore the default icons?

(Daniela) #11

But your community is hosted by discourse.org?

I see a lot of stylesheets here…

Try open the stylesheet that start with this description:

// Theme: Migrated from Site Text
// Target: common scss
// Last Edited: 2017-04-26 14:19:44 UTC

/* Discourse overrides ------------------------------------ */

You need to comment out the line 1297

[aria-hidden="true"] {
    display: none !important;

(add /* before [ and add */ after })
It works for me, and then pray that your predecessor come back to explain you all the changes he made.

Please, note that this is not a real fix, only a momentary workaround to let your users click on the buttons. You need to review your customizations.

The result:

(Aisha I) #12

Thank you so much! That works for now and I’ll see if my team and I can figure out the customizations.